Moving toward Z-wave and Zigbee

There is a dropdown in PaperUI and HABmin for me. I think occasionally I have needed to restart OpenHAB to get the dropdown to show though.
I think missing the dropdown is an indication that OH has not detected the serial ports.

I unplugged the stick, uninstalled the Zigbee binding, then re-installed Zigbee and plugged the stick back in. Same behavior.

I’ve restarted multiple times and nothing. I am still running 2.4 - do I need to upgrade to 2.5 (milestone or snapshot)?

I think Milestone 6 is scheduled to be released today and the stable 2.5 in two weeks.

Is 2.5 required to get this stick working, or should it be working with 2.4?

It should work fine with 2.4. Your problems are not with the binding - not being able to open the ports is a more fundamental issue and the binding doesn’t interact directly with the serial driver anyway.

Unfortunately I’m not sure what else to suggest if you’ve done all the standard stuff (permissions, command line parameters etc) which I think is the case from a quick scan of the above.

1 Like

Ugh! I went back through everything and apparently I forgot the step of adding openhab to the dialout group. Now I can see the controller.

Next hurdle: I don’t see any Zwave devices although I installed 2 new devices (one on the list of supported devices and one not) yesterday. One is a GE branded fan controller, and the other is a GE branded light switch. I also have several Hue devices, none of which are showing up when I search for Zigbee devices.

What now?

Described what you mean by “installed”. How did you pair the devices to the controller?

Same for the Hue, how did you pair then to the controller?

I got the Z-wave devices working. There is a little button on the switch below the paddle, and I hit that while OpenHab was searching for devices. That didn’t work. After some more fiddling I determined that it was hitting the paddle on during the search that actually worked. I now have 2 devices, but one of them is not in the database. I see some threads on that, so I’ll look into it.

On the Hue side, I don’t know how to do that. I have hue bulbs, so there is nothing to press on the bulb. How do I put them into a discoverable state?

I don’t use Hue but I would assume what ever the menus says to do to pair the bib with a hub you also need to do after you put the coordinator into pair mode just like you did for zwave.

Hmm,

So as I mentioned I got a GE 14297 Fan Controller, which doesn’t show up on the list, but I have full control of it now that I finally got through discovery.

On the other hand, my GE 46201 shows up as an unknown device even though it does show up in the database.

Is the 46201 something that has been added post 2.4 stable?

Hue bulbs are difficult to reset. You need a hue remote control to do this.

I followed your link and fount this at the bottom.

image

I believe Milestone 6 is ready to be released tomorrow. That should have the latest version of this device.

Ah - so if it’s already connected to a bridge it won’t connect to another zigbee controller?

Simply put, yes…

To be more correct - if a device is already included into one network, then it can’t be included into another network. Each network can have multiple controllers, but only one coordinator.

I actually went the “hue-thief” route and it worked brilliantly on 5 regular bulbs and 1 color bulb. But 2 other regular bulbs (same model as the 4 that worked) had trouble.

When I scanned tried searching for it the first time around, it came in as “unknown Zigbee Device” rather that “Philips XYZ Bulb” like the others did and there was no channel to control. So I deleted the new item, stopped openhab, re-did the hue-thief thing, started openhab and searched again and it found nothing at all.

I was able to re-connect it to my Hue hub just fine, but whenever I search for it in Openhab it fails.

Any thoughts?