MQTT 2.4 floods openhab.log

Hi,
I’m about to move my MQTT Items from mosquitto to the all-new embedded MQTT broker. Thanks for that by the way. After migrating my wifi wall switches i noticed that my openhab.log gets flooded with the entries below.

2019-01-24 09:21:10.499 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8E:11:68>
2019-01-24 09:21:19.646 [INFO ] [messageLogger                       ] - C->B PINGREQ <ESPClient_60:01:94:8C:BD:B2>
2019-01-24 09:21:19.647 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8C:BD:B2>
2019-01-24 09:21:20.733 [INFO ] [messageLogger                       ] - C->B PINGREQ <ESPClient_60:01:94:8E:11:68>
2019-01-24 09:21:20.735 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8E:11:68>
2019-01-24 09:21:29.645 [INFO ] [messageLogger                       ] - C->B PINGREQ <ESPClient_60:01:94:8C:BD:B2>
2019-01-24 09:21:29.648 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8C:BD:B2>
2019-01-24 09:21:30.984 [INFO ] [messageLogger                       ] - C->B PINGREQ <ESPClient_60:01:94:8E:11:68>
2019-01-24 09:21:31.006 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8E:11:68>
2019-01-24 09:21:39.646 [INFO ] [messageLogger                       ] - C->B PINGREQ <ESPClient_60:01:94:8C:BD:B2>
2019-01-24 09:21:39.650 [INFO ] [messageLogger                       ] - C<-B PINGRESP <ESPClient_60:01:94:8C:BD:B2>

Presumably they are some kind of keep alive ping. These kind of log entries never showed up in my mosquitto log and I consider them as very useful unless debugging. So may be someone can help me how to supress these log entries.

Thanks very much

Those are log level “Info” only. Please consider setting the embedded broker to “Warn” instead, it is indeed really noise.

How do you find the correct package to change the log level for?

I tried the following which didn’t work.

log:set WARN org.eclipse.smarthome.io.mqttembeddedbroker

Now, I posit the question if there is a simple way to find out which package to mute?
The Logging documentation only states that the package.subpackage is in most cases a binding, but where do I find that binding?

Do I have to look at the code on Github, or is it accessible using e.g. the cli?
Tried bundle:list | grep MQTT doesn’t give more information than the ID’s.

(Perhaps there should be an ID in the log:
2019-01-24 09:21:39.646 [INFO ] [ 123] [messageLogger ] - C->B PINGREQ <ESPClient_60:01:94:8C:BD:B2>
allowing a user to set e.g. log:set WARN 123)

log:set WARN messageLogger maybe.

The problem is, there was a bug in our current used version of the embedded broker where the full package id is not part of the logging message. So the filter org.eclipse.smarthome.io.mqttembeddedbroker will not work for that particular log message.

1 Like

Try this:

log:set warn smarthome.event

This one did the job, but I also lose the PUBLISH events. Will there be a fix for this as you pointed out that it’s a bug?

Thanks so much for your effort and contribution.

Not in the near future. The repositories are restructured at the moment. But at some point we’ll update the embedded broker to the newest version again.