MQTT 2.4 java.lang.Exception when creating generic MQTT thing

I’m trying to use the MQTT 2.4 binding to interface my boiler to my OH system. I’ve read through the MQTT documentation and created an embedded broker, turned on debug logging and can see that the boiler interface has connected to it. However, whenever I try to create a generic MQTT thing I get a message about a java.lang.Exception.

I’m configuring the MQTT thing like this:

Clicking on save gives this result:

Am I doing something wrong? I’ve searched for similar problems and this looks like it might be a bug in MQTT 2.4. If I’ve hit the bug then how can I get this to work without upgrading my entire system to a 2.5 snapshot?

Sounds like the (known) bug in 2.4. You probably have to restart OH.
In 2.5 this one is solved.

Ah! Thanks! That solved it!

My understanding from reading other reports of the bug was that you couldn’t use the PaperUI to create the thing. I didn’t realise a reboot would solve the problem. Thanks again! :slight_smile: