Mqtt action in openHABian v1.5

I dont see MQTT Action in PaperUI -> Addons -> Actions
I wonder how to install it or is there any workaround (I have rules with “publish” function)

If you are running openHAB 2.4 or later, the MQTT Action has become legacy. You can see it by toggling the switch in the Server configuration to show legacy add-ons. You would also need to install and configure the MQTT 1.x version binding.

A better solution would be to use the Action that just comes with the MQTT 2 binding. See There is nothing extra to install beyond the MQTT 2 binding.

new MQTT binding is a big mystery to me, installed, configured embedded mqtt broker and added as Thing, also tried


(tried also with mosquttio broker installed using openhab-config) but was not able to do anything further as googling I gave up as there is too many problems (it could be nice to have some error logs concerning MQTT)

…so that I installed legacy MQTT Action + MQTT Binding and since last version (2.4) something has changed as with my last configuration it didnt work. Finally made it working changing mqtt.cfg (removed mosquitto.client=xxx) and now my config looks like this: