Mqtt and homematic via hm2mqtt

Hi folks

i’m using openhab with my homematic ccu2 over three years now, currently 1.8.
I’m currently trying to "simplify my setup and therefore trying to get the hm2mqtt to work.
Unfortunately, the hm2mqtt adresses the components in the following format: hm/set/HM-LC-Dim1T-FM MEQ0401693:1/LEVEL
So the : is interfering with openhabs mqtt binding definition policies.

Is there any chance to get around this? I’m trying to avoid writing rules for this scenario.

Thanks for your inputs

Have you tried to escape the “:” like this: \: ?

Yes i have.
I also tried escaping it with \u003A. The Logfile interpreted it correctly, but still got the error

Binding configuration of type ‘mqtt’ of item âl_eg_gangâ could not be parsed correctly.
org.openhab.model.item.binding.BindingConfigParseException: Configuration ‘local:hm/set/HM-LC-Dim1T-FM MEQ0401693:1/LEVEL:command:*:default’ is not a valid outbound configuration: Configuration requires 5 parameters separated by ':'
at org.openhab.binding.mqtt.internal.MqttMessagePublisher.( ~[na:na]
at org.openhab.binding.mqtt.internal.MqttItemConfig.( ~[na:na]
at org.openhab.binding.mqtt.internal.MqttGenericBindingProvider.processBindingConfiguration( ~[na:na]
at org.openhab.model.item.internal.GenericItemProvider.internalDispatchBindings( [org.openhab.model.item_1.8.3.jar:na]
at org.openhab.model.item.internal.GenericItemProvider.internalDispatchBindings( [org.openhab.model.item_1.8.3.jar:na]
at org.openhab.model.item.internal.GenericItemProvider.processBindingConfigsFromModel( [org.openhab.model.item_1.8.3.jar:na]
at org.openhab.model.item.internal.GenericItemProvider.modelChanged( [org.openhab.model.item_1.8.3.jar:na]
at org.openhab.model.core.internal.ModelRepositoryImpl.notifyListeners( [org.openhab.model.core_1.8.3.jar:na]
at org.openhab.model.core.internal.ModelRepositoryImpl.addOrRefreshModel( [org.openhab.model.core_1.8.3.jar:na]
at org.openhab.model.core.internal.folder.FolderObserver.checkFolder(

You will probably need to file a feature request or bug on github to get changes made to the code.

having the same problem here. anyone got an an answer yet?