MQTT binding disappeared after upgrade 3.2 to 3.3 - and cannot be installed again?

Hi there,

I upgraded my installation from 3.2 to 3.3 and noticed that the MQTT bridge seemed to have disappeared. It was however installed according to the bindings screen.
Deinstalled it, stopped OH, cleaned the OH cache, startet OH again and installed the binding again. Nope, still not there.
I would expect the configuration to appear in the “Other services” section of the “Settings” screen. But is is simply missing there.

Any hint where to start?

That setting is no more. It was always associated with the embedded MQTT broker which hasn’t worked for quite some time and has been removed for quite some time. So, since the embedded broker is gone and to keep the binding consistent with all the other bindings the “system broker” settings have been removed. You need to manually create the MQTT Broker Thing. Go to the inbox, click the +, select MQTT and then MQTT Broker thing and fill out the connection information.

Once that works, go to your MQTT things and change the “Parent Bridge” to the newly create MQTT Broker Thing.

Okay, just got it done - thanks! A hint to the documentation, just this explanation added would make the binding page doc perfect ,-)


Breaking changes like this are documented in the release notes.

Support for the MQTT System Broker has been removed. Replace ‘mqtt:systemBroker’ things with ‘mqtt:broker’ things.

It’s always a good idea to read that section before performing the upgrade so you won’t run into any unexpected issues. :wink: