MQTT Binding wo

mqtt
Tags: #<Tag:0x00007f1e654addc0>
(Tyler W) #1

Trying to setup an MQTT binding, and having some issues…

broker.things

Bridge mqtt:broker:broker [ host=“192.168.1.5”, secure=false, username=“username”, password=“password” ]

mqtt.things

Thing mqtt:topic:mything (mqtt:broker:broker) {
Channels:
Type switch : lamp “Kitchen Lamp” [ stateTopic=“lamp/enabled”, commandTopic=“lamp/enabled/set2” ]
}

mqtt.items

Switch Kitchen_Light “Kitchen Light” {channel=“mqtt:topic:broker:mything:lamp” }

I can’t get it to publish or receive from the broker on the indicated topics :confused:
The broker seems to connect just fine though, and I can use the broker from other clients as well.

I pulled the configuration from the binding example, and have tried it in many different configurations. I have the switch bound to a sitemap so I can toggle it on basic UI, but to no avail… nothing happens on MQTT even though it shows as toggling and linking in the logs.

I’ve also tried
broker.things

Bridge mqtt:broker:broker [ host=“192.168.1.5”, secure=false, username=“username”, password=“password” ]
{
Thing topic mything {
Channels:
Type switch : lamp “Kitchen Lamp” [ stateTopic=“lamp/enabled”, commandTopic=“lamp/enabled/set2” ]
}
}

But having it in one file didn’t seem to help either

0 Likes

(Tyler W) #2

Switch Kitchen_Light “Kitchen Light” { channel=“mqtt:topic:mything:lamp” }

fixed it up… for anyone needing it… broker doesn’t need to be in the channel definition. yay…

0 Likes