MQTT broker problems in OH3

Hi I’ve upgraded to V3 a few months ago. Upgrade seemed to go reasonably ok.
Was using the embedded MQTT broker successfully in OH2. This continued to work after the upgrade although I understand it’s no longer available in 3. A few weeks ago it stopped working so I decided to remove and go with Mosquito. I couldn’t really see how to remove as it’s no longer referenced in the UI. I removed some references to it from things files and removed a related. Bin file.
Installed Mosquito via openhabian-config. Install seemed to go ok.
Problem is when I try to add a broker thing and connect it to the MQTT server, it won’t. I’ve tried with and without authentication. I can see a log for Mosquito and there are some entries for my existing devices trying to connect to it. Tried restarting it via sysctl and it seems to restart ok.
-Anyone have any pointers as to how to get to the bottom of this?
-Also I see it’s possible to install a System MQTT broker from the UI. From what I read an external broker was recommended, any advice on this?


I had a similar problem when switching to the broker installed with openhabian.
Is mosquito running? What does
sudo systemctl status mosquito

In my case it was not running due to some permission problem. I used openhabian-config to fix permissions and restarted mosquitto.

If it runs, are you able to connect to it from the command line with
mosquitto_sub -h localhost -t “#”
Finally you have to check the openhab log.

Hope that it may help

The status of sudo systemctl status mosquito showed ‘Active(exited)’ Seemed that for some reason the service wouldn’t start or stay running. I remove everything I could find related to the old embedded broker but still not working. Eventually tried running interactively and it was fine. Tried reinstalling via openhabian-config but it was the same. I removed and then intstalled on the cli, independently of openhabian-config. That seemed to work, no idea what it does diffferently but now it runs as a service and status shows Active(Running).

Thanks for the advice.