MQTT Eventbus stopped working?

Just wondering if anyone has the same issue. I’ve had MQTT event bus working for years and sometime in the past 2 weeks it’s stopped working. I use it to sync up 2 instances of OH2, both running snapshots. Server side I don’t see any attempts at all coming from the slave. I’ve put transport and mqtt into TRACE, and I don’t see anything super obvious, it’s as if it’s not event paying any attention to the config file for eventbus.

I’ve already remove the /var/lib version of the mqtt stuff, reinstalled action, persistance, and mqtt. Nothing seems to work. Any ideas?

What version of OH are you running?

Did you make any changes in the past two weeks (updated OH to another version, updated your broker, etc.)?

Yup, latest OH(snapshot) it’s broken apparently. I reverted the slave instance to OH stable and it’s working fine. Something in the new snapshot breaks the eventbus mqtt entirely.

You might file an issue on the openhab1-addon’s github repo letting the devs know.

Normally I would, but I don’t know that it has anything to do with the addon. I think it may be an issue w/ the backend processes to be honest. It’d be real nice to have an OH2 native MQTT binding, this might push me to make one.

I’ve been bit a few times already by the backend, enough to make me stop using snapshots or even testing at this point. This was my first time back to the snapshot releases in a while and reminded me why I stopped using that on my main server.

There already is one, but development dressed for some reason. I don’t know what state it is in but at one point it looked really close to being ready to be included in the baseline.

Not only use it a 2.x binding but it comes with it’s own broker so you don’t need to run mosquito if you don’t want to.

Yea, I saw the one with the broker, but I don’t need or want another broker. I have about 20 devices that use my MQTT, and I really don’t want to have to set that all up again. Just having an MQTT setup that is solid and works well would be great.

My understanding was you don’t have to use it set up the internal broker that comes with it. It’s just an option.

Though, when I look at the level of effort to take an existing binding the last hundred yards plus a little extra config compared to starting a whole new binding from scratch, the scale definitely tips to one side.

Same experience here with snapshot #1356.
Maybe related to this issue:

Any updates on this topic?

The issue has been fixed a while ago.