MQTT has worked 100% for last three years, now failed

My System is over three years old and has been working very well. Last week after upgrading MQTT stopped working and openhab is no longer able to receive or send data. I searched this forum and so tried uninstalling 2.4.0 snapshop and adding MQTT1 to the addons.cfg. No luck at all, any suggestions?

My MQTT.cfg file


Enable legacy addons in paper UI (forum search) or via the addons.cfg.

Thanks David - tried that (adding MQTT1 to addons.cfg and uninstalling 2.4.0) - didn’t work

There was a daily snapshot last week where MQTT (legacy) did not work. I solved it then by jumping to milestone 8. Have you tried the 2.4 release?

Thanks, is 2.4 different to 2.4.0?

To be honest, I have no idea how to define the version in addons.cfg. Because mqtt1 and mqtt2 have actually the same binding id which is “mqtt”. You will always get the latest version.

In paper UI you can separately download v1 and v2.

Thanks David

How do you install version 1 - I don’t seem to have that option?

Starting to wonder if there aren’t two issues - one related to openhab and one related to broker mosquitto?

The legacy binding is “mqtt1”. All 1.x version bindings have a 1 after them. So, for example, the only HTTP binding is “http1”. “mqtt” will install the 2.4 version binding. Here is my addons.cfg which installs both.

binding = zwave,astro,expire1,network,http1,mqtt1,zigbee,networkupstools1,nest,mqtt

Going back to the second post, you need to enable legacy bindings for it to show up in the list there. The setting is under Configuration -> System -> “Include Legacy 1.x Bindings”. Toggle that ON and both versions will be shown in Add-ons >_ bindings.

For addons.cfg users, the binding name you need to use will be the part after “binding-”.

Thanks - There is an issue with the mosquitto broker failing and terminating on socket error - working through this now

The MQTTv1 binding id is mqtt1
and MQTTv2 is mqtt

My addons.cfg:

binding = http1,exec,nest,network,caldav-command1,mqttitude1,mqtt1,astro,expire1,systeminfo,samsungtv,openweathermap,groheondus,mqtt