MQTT issue after upgrade to version 2.5.8-1

  • Platform information:
    • Hardware: Raspberry Pi 3 model B rev 1.2
    • OS: Linux 5.4.51-v7+
    • Java Runtime Environment: 1.8.0_265
    • openHAB version: 2.5.8-1

Hello, I did the upgrade to 2.5.8-1 and I had many issues, but now I’m stuck with Mosquitto problem, I’d apprecciate any help…

mosquitto.service - Mosquitto MQTT v3.1/v3.1.1 Broker
Loaded: loaded (/lib/systemd/system/mosquitto.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2020-08-24 15:24:52 -03; 1min 13s ago
Docs: man:mosquitto.conf(5)
Process: 654 ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf (code=exited, status=1/FAILURE)
Main PID: 654 (code=exited, status=1/FAILURE)Aug 24 15:24:52 openhab systemd[1]: mosquitto.service: Service RestartSec=100ms expired, scheduling restart.
Aug 24 15:24:52 openhab systemd[1]: mosquitto.service: Scheduled restart job, restart counter is at 5.
Aug 24 15:24:52 openhab systemd[1]: Stopped Mosquitto MQTT v3.1/v3.1.1 Broker.
Aug 24 15:24:52 openhab systemd[1]: mosquitto.service: Start request repeated too quickly.
Aug 24 15:24:52 openhab systemd[1]: mosquitto.service: Failed with result ‘exit-code’.
Aug 24 15:24:52 openhab systemd[1]: Failed to start Mosquitto MQTT v3.1/v3.1.1 Broker.

Are you using openhabian?

Have you tried restarting your device?

Was Mosquitto installed before you did the upgrade?

Yes, I’m using Openhabian, restarted many times, and YES, Mosquitto was fully working before upgrade…

I would reinstall mosquito. Seems like something happened. The upgrade to the latest openHAB should not update or change mosquito, so something unknown happened.

I had an issue like this once and it was simply a corrupt sd card. My update went well but reboot did not for an unknown reason. I reinstalled the app that was failing and it worked again.

I finally could make things work, but I had to install everything again from scratch, but the main difference is that I hadn’t install the MQTT from Openhabian, BUT now I needed to install MQTT Broker Moquette, which wasn’t installed BEFORE the upgrade.

I don’t know why but now things are working in the current version 2.5.8-1… I think that it should be advised that it is MANDATORY to do this for this upgrade. Maybe because of this I had the crash at the system…


You need some kind of MQTT broker to use MQTT in openHAB. The broker is not part of openHAB.

You can choose to use Mosquitto or you can choose to use Moquette (which is “the embedded broker” but still a separate service) or you can choose to use something else.

None of this is mandatory, none of it needs changing because of any openHAB update. What went wrong for you, we’ll probably never know now.