MQTT problem after 2.4 update

Hey guys,

everytime I update openHAB something is not working anymore. I like the new message about the bindings to take care of, because there was a change. Before I had many problem with the Yeelight and so on. I am still on a very old version of coasterli, because it works best.

Right now I run into a MQTT-problem. I was using the MQTT-Action and it was working fine for months/years now. I already fixed it several times and so I tried to again. This time the “MQTT action” is missing - I am not able to install it. The documentation page of it is still online and there is nothing written about it…

I really love openHAB (tried several other things like domoticz before), but these changes are not “nice”. I want to have my home reliable. Like everything is connected to openHAB at my place…

Edit: Tried to install the action with “bundle:install action-mqtt”, but there is an error:

Bundle IDs:
Error executing command: Error installing bundles:
Unable to install bundle action-mqtt: org.osgi.framework.BundleException: Error reading bundle content.

If your system was running without issues, why did you update in the first place?
On your mqtt problem, which mqtt binding are you using?
There was a problem getting the mqtt1 binding to work with the mqtt action, and there is a new mqtt2 binding, which doesn’t have/ work with mqtt action ( although a rule just can do what you want).

And lastly, if you seek for help with a specific problem please state such in the header!

I just go to my Pi like every two weeks and do “apt-get update” and “apt-get upgrade” to have all security and so on. And so I went to 2.4 release build.

Right now I have both bindings installed. MQTT Action is showing to install again with this option:

Are the commands the same for the 1.X binding and 2.X binding? So just uninstall 1.X binding (and action now)?

And thank you very much for your fast answer!

Here is one of my items:

Switch		office_socket_sonoff1					"Andreas Bildschirme"																									["Switchable"]				{mqtt=">[broker:cmnd/sonoff-offandypc/POWER:command:ON:1],>[broker:cmnd/sonoff-offandypc/POWER:command:OFF:0],<[broker:stat/sonoff-offandypc/RESULT:state:ON:1],<[broker:stat/sonoff-offandypc/RESULT:state:OFF:0"}
Switch		office_socket_sonoff1_status																																								{mqtt="<[broker:tele/sonoff-offandypc/LWT:state:MAP(reachable.map)]"}
Number		office_socket_sonoff1_wifi																																									{mqtt="<[broker:tele/sonoff-offandypc/STATE:state:JSONPATH($.Wifi.RSSI)]"}
String		office_socket_sonoff1_msg																																									{mqtt="<[broker:tele/sonoff-offandypc/INFO1:state:JSONPATH($.*)], <[broker:stat/sonoff-offandypc/STATUS2:state:JSONPATH($.*)], <[broker:stat/sonoff-offandypc/RESULT:state:JSONPATH($.*)]"}

The commands are totally different. With the l"include egacy bindings" you get access to the mqtt1 again and can use the config as before.

Okay thank you.

I will go with the old action and binding first then. When I have some spare time I will take a look into the new binding.

Thank you!

Edit: It is working again now! :slight_smile:

Is has an action now: https://www.openhab.org/addons/bindings/mqtt.generic/#rule-actions

13 posts were split to a new topic: Sonoff MQTTv1 issue with switch