MQTT problems after upgrade to 2.5.3

Updated to OH 2.5.3 today an now I’m experiencing problems. My log is being flooded by the following messages:

2020-04-18 14:34:57.422 [WARN ] [.incoming.MqttIncomingPublishService] - QoS 0 publish message dropped.

I can barely read the log because hundreds of lines coming in every second.
Also my commands being executed are being delayed by approx. 20-30 seconds.

Any idea what I could do to get it working again?


Restart OH a few times.

sudo systemctl restart openhab2

Just make sure to watch the logs and allow OH to fully restart between each restart. Usually takes me 2 restarts for everything to start working again.

1 Like

Restarted three times, even cleared the chache - no change, warning messages still flooding my log…

Set the mqtt binding log to DEBUG or TRACE and see if you get any additional info that may help.

Which of these should I trace/debug?

openhab> bundle:list -s | grep mqtt
203 x Active x  80 x 1.2.2                   x org.eclipse.paho.client.mqttv3
219 x Active x  80 x 1.1.2                   x com.hivemq.client.mqtt
251 x Active x  80 x 2.5.3                   x org.openhab.binding.mqtt
252 x Active x  81 x 2.5.3                   x org.openhab.binding.mqtt.generic
253 x Active x  82 x 2.5.3                   x org.openhab.binding.mqtt.homeassistant
254 x Active x  82 x 2.5.3                   x org.openhab.binding.mqtt.homie
263 x Active x  80 x 2.5.0                   x

Start with this one.

BTW what broker are you using, Mosquitto or the Embedded one?

Mosquitto - and it has been in place for approx 3+ years without this issue.
In PaperUI I see MQTT binding (2.5.3) installed; under services I can see a service called “MQTT system broker connection”. Could this cause a problem?

I changed the loglevel first to trace, then to debug - when I did this, the messages stopped for approx. 10 seconds. Afterwards it went back the “flooding” mode. Need to download the logfile(s) as I’m unable to see anything with frontail

As you can see, every 8 minutes 16MB of logs are filled up:

No that is normal.

Have you tried uninstalling/reinstalling the binding?

Not yet, currently doing it. Also, I found the following addons in my addon folder - could the paho client cause the troubles in this version?

Yes I would remove any jar file that you are not using.

Uninstalled & installed the MQTT binding, removed all jar files except WLED, stopped opehab & cleaned the chache. Now reboot is running…

After cleaning the cache OH will take a few minutes to fully restart and you may need to do 1-2 more restarts.

Nope. Didn’t help. Now I think about setting the log level to error in order to stop the filling of my logs…

After going crazy for an afternoon, I ended up with these messages in my log:

2020-04-18 19:21:12.567 [hingStatusInfoChangedEvent] - 'mqtt:topic:mosquitto:esp_mqtt' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Session expired as connection was closed.

2020-04-18 19:24:22.192 [hingStatusInfoChangedEvent] - ‘mqtt:broker:mosquitto’ changed from OFFLINE (COMMUNICATION_ERROR):$AnnotatedConnectException: Verbindungsaufbau abgelehnt: / to OFFLINE

2020-04-18 19:24:22.215 [hingStatusInfoChangedEvent] - 'mqtt:broker:mosquitto' changed from OFFLINE to OFFLINE (COMMUNICATION_ERROR):$AnnotatedConnectException: Verbindungsaufbau abgelehnt: /

Since I didn’t change anything in my config, I guess I’ll open a case on github now.

Are you running this on a RPI with SD card? If so check the power supply is good and try using a different SD card as they are prone to corruption after some time.

It’s an RPi, but only the boot partition is on SD card, the rest has been moved to an USB SSD two years ago. After a few hours the problem vanished and I don’t know why. But at least it’s working again.