MQTT temperature trouble [Solved]

This driving me crazy! It is working now But i have NO IDEA WHY!?

I run on a Raspberry 3 openhab 2.
i send via mqtt data to the same raspberry: the output of my topic subscribe are:

    mosquitto_sub -v -h localhost -p 1883 -t '#'
    terra/weather/Temperature 21.77
    terra/weather/Humidity 40.26
    terra/weather/Pressure 1000.51

Now i add the mqtt addon to my openhab2 services mqtt.cfg with:

    # URL to the MQTT broker, e.g. tcp://localhost:1883 or ssl://localhost:8883

In my Item i add the line:

`Number    GF_Terrace_Temperature    "Temperatur [%.2f °C] "         <temperature>   (GF_Terrace, gTemperature)       {mqtt="<[mqttbroker:terra/weather/Temperature:state:default]"}`

I get only this error openhab log:

2018-03-31 10:49:43.860 [ERROR] [org.apache.felix.configadmin        ] - Cannot use configuration org.openhab.mqtt for [,, id=307, bundle=208/]: No visibility to configuration bound to mvn:org.openhab.action/org.openhab.action.mqtt/1.11.0

on my Basic UI i only get -°C

no temperature is showing

I check all setting countless times: (
Anybody can help?

Having read the first line of your post gives the impression that your problem is solved.
It would be nice if you would state that in the topic (like adding “[Solved]”) and also label new entries in your post with “Edit”.

but still no idea why it works :slight_smile: