MQTT/Z-Wave Values are NULL, why?

I have two Tasmota devices which are running via MQTT and they show me a value of NULL.
The same is with one of my Z-Wave devices, it also shows NULL on all Channels.

NULL means that the Items have not received any updates since openHAB started. It can take quite some time for battery powered zwave devices to report some info (e.g. battery level could only be reported once every couple of days) and until it does so those Items will remain NULL. You can avoid this by using persistence and restoreOnStartup which will set the Item to the last value it had before openHAB went offline.

I can’t comment on the MQTT except to say that unless the messages are sent with the retained flag set, your Items will remain NULL until a new message is published.

Ok, but every other Channel is NULL too

The openHAB uptime is about 14 hours, it should receive any data within this time or not?

All I can say is those Items have never received an update since openHAB started. So either the binding is broken, the device is broken, or the device has simply never reported any information. It’s a battery powered device so any of these could be the case.

I think i found the Z-Wave Problem, im using two Controllers, one is in my living room and the other is in the garage.
6 devices from my living room, seems to be connected to the garage controller.
1 garage device and one living room device seem to be connected to the living room controller.

Can i tell the devices which controller they should use? Or do i need to pair everything again?

I don’t really know how to create a configuration with multiple controllers. I think it’s possible to have a main controller and a secondary controller that somehow work together but I’ve no idea how to make that work and have seen very few people mention having that sort of set up. Almost all OH users have just the one controller. You’ll need to do some research on how zwave works with multiple controllers in such a configuration. Or you’ll need to set up two independent zwave networks and configure both controllers in openHAB.

My understanding is a device can only be paired with one controller at a time.


I just fixed it by setting the correct “Master” Tag on the main Controller. Than i removed my device and added it again to openHAB, now it uses the correct Controller and it’s sending data.

The MQTT Problem was solved by adding Jinja and JSONPath Transformation.