My.openhab offline?


im using a raspberry 2 with raspbian jessie and configured openhab.

I wanted to setup the my.openhab addon and followed the instructions but my openhab says always that im offline.

The log file under “logs” openhab.log does not show actual datalogs. I tried to “sudo service openhab restart” several times and “service openhab status” gives me also an sucessful answer:

pi@raspberrypi ~ $ service openhab status
● openhab.service - LSB: Kurze Beschreibung

  • Loaded: loaded (/etc/init.d/openhab)*
  • Active: active (exited) since Die 2015-12-15 14:01:03 UTC; 4min 54s ago*
  • Process: 20211 ExecStop=/etc/init.d/openhab stop (code=exited, status=0/SUCCESS)*
  • Process: 20216 ExecStart=/etc/init.d/openhab start (code=exited, status=0/SUCCESS)*

How can i see whats openhab doing and fix the problems?

The fact that openhab.log is empty and the service status says “Active:active (exited)” it mean your openHAB server is not running. For some reason it is failing to start. There will always be at least a few lines in openhab.log when it starts. If you see nothing then it is never running.

Look at your syslog to see if there is any sort of error printed when it starts up.

How did you install openHAB? The best installation approach is to use apt-get which should handle most of the permissions and similar problems.

Thanks for your reply.

I followed this guide in german :

I now started openhab (sudo ./ and i get no critical errors.

I can now also acesss my site over http://localip/
but at the login window i dont know what credantials to use. my mail adress and password from my openhab doesnt work either my local pi user …

Your Weather binding looks to be broken as does your rrd4j persistence. But none of that will impact the operation of my.openhab

Sorry, just edited my post above.

I now cant login to the login window.

Server says

: but i use the local ip…

Fixed IT!
i add a user to the users.cfg and that works!
But on myopenhab it says still “Offline”.

I set correct UID and Secret…??

Usernames and passwords for local access are in /etc/openhab/configurations/users.cfg. It is of the format


When you configure my.openhab I think it automatically adds an ifttt user. But it shouldn’t be asking for a user and password if you have security set up as EXTERNAL. Double check that the security:option=EXTERNAL is set near the top of openhab.cfg.

If it is set to ON then that would explain both why it is asking for the password and why my.openhab isn’t working.

Yes, EXTERNAL is set correct and also Subnetmask (eg.

I don’t think the netmask supports that format. Use the format illustrated in the previous commented out:

ok will try that.

a other problem i was debugging openhab to test what packages have been sent to my milight controller.

i saw that openhab dont recognizes my changes in my openhab.cfg cause i set all fine (deleted the # at bridge and port but the log shows:

AGAIN my FAULT! in the cfg i dont deleted the < and > of Milightid1.

i replaced them now trough bridge1 and now my loght does what it should!

Maybe others find this helpful but in the forums and some self testing its easy to find out the problems.

Now i can play around - THANKS!