Mycroft Openhab Skill

skill
mycroft
3rd
Tags: #<Tag:0x00007fd30f73ceb0> #<Tag:0x00007fd30f73cd70> #<Tag:0x00007fd30f73cc08>

(Markus Storm) #21

Okay. Let’s stay peaceful, then. Thanks anyway.


(Lukas) #22

@mstormi what are your issues with recognition?

I got it working fine with a respeaker, micarray and Ubuntu, biggest issue ther is the wakeword detection. But The “binding” somehow wont distinguish between multiple items of the same room, e.g. if i tell mycroft to “switch off the livingroom light” it will switch off the livingroom outlet instead as long as my items both have livingroom in their description. Changing the description to “livingroomlights” and “livingroomoutlet” seems to help mycroft to distinguish…
@mortommy Any ideas why? (great binding though!!!)


(Markus Storm) #23

Got it to work meanwhile. Yes the only remaining issue I feel to be the wakeword recognition, too. Although that’s what every Mycroft user has been using forever without problems, so I rather attribute that to the audio quality in general. Thus to the physical situation incl. Respeaker and the whole software chain attached (pulseaudio, sphinx).
I’ve therefore thought about trying a bluetooth mic instead as that’s portable and can be moved to a better place to match the room’s acoustics. Still struggling with the software layers, though, pulseaudio in particular.


(Lukas) #24

Well i have played around with the wakeword settings a little and since the normal voice recognition seems to work quite well with the mic array, my guess is that its more an issue of the right settings and pocketsphinx. When you try the bt mic, are u replacing the array or is there a way to use multiple mics at the same time? (Yes i could just have a look at the mycroft forum but i am a bit lazy right now :slight_smile:)
Greetings, lukas


(Per Manholm) #25

I am about to tryout mycroft on picroft with openhab.
You write in the documentation to add ip-adress and port of openhab-server to the mycroft.conf file.
What port is to be used?

And btw, there is a typo "mycoft.conf"

Looking forward to get mycroft up and running!

/Per


(Tommaso) #26

Hi.
The default port number is 8080.
Yes there’s an error, it is mycroft.conf. Thank you.


(Per Manholm) #27

Thanks.

Got my first lightfunction to work after a lot of trials :slight_smile:

One tricky part is the naming of the items. My names are in Swedish (homekit is working fine with Swedish), while mycroft is not recognizing the words at all.
In my sucessful attempt I made a “clone item” with a simple name like “Office” and mycroft could control it.

Have you guys any other experiences, tips?

I run mycroft on picroft, a simple microphone and speaker.


(Stefan Zieren) #28

I use a Playstation Eye microphone. Bought it on ebay for € 6. Works perfectly well for me.


(Der Oetzi) #29

Hi there I’m looking for an “Cloudless” Home Assistant for some weeks and finally found mycroft yesterday. I will give it a try and I’m very happy to see there is already a skill for openhab. Thanks for that.
Since I’m a german native speaker, I will try to run Mycroft with german language. For this reasons may I contribute to this skill by doing translation and testing for german language support?

I although have some ideas for some more features for this skill I maybe wan’t to discuss later. But first I wan’t to try to do the basic setup running in german.


(James Derrick) #30

Hi,

The Mycroft discussion forum has more information on binding development, and setup which is actively improving how multiple languages are supported.

I wrote a detailed step-by-step guide on how to configure both OpenHAB and Mycroft which I hope will help get you up and running:

Depending on your needs, there are multiple hardware options ranging from Linux desktop plugins, software on a Raspberry Pi (PyCroft), or the Mycroft Mark 1 and Mark 2 devices. The Mark 2 is under development now, with a recently ended Kickstarter and a near-identical IndieGoGo campaign.

The current Mycroft Python code has if statements for English and basic Italian support and this could be extended for the German language but this approach doesn’t scale well.

Recognising support for many different languages is needed, a recent Mycroft blog post from their architect mentions improvements and new Skill Translation tools.


(Tommaso) #31

Hi.
You can translate the voc, dialog and rx files from the official repository. As you can see someone already made a translation to italian.
Something should be changed in the init.py file too.
Anyway if you get a working german version please don’t forget to contribute making a PR.


(Scott) #32

There’s also a Mycroft desktop widget for the KDE Plasma desktop, if you’re a Linux kinda person.

I’ve got it running right now and it’s doing a decent job. I’ve yet to finish my OH setup, so that bit isn’t working yet. But I can ask him the time, weather, Wikipedia, etc.


(Tommaso) #33

Hi,
I’m glad to announce that the mycroft-openhab skill is now part of the 18.02 mycroft skill branch, so get it via voice asking: “install openhab skill”.


(Thomas) #34

Hello Oetzi,

do you know if any progress has been made on the translation of the obenhab skill into german?

Best regards

McFly


(Tommaso) #35

Hi,
there’a a PR about German translation, before to be merged I have to change something in the code, but stay tuned I think I can get it in these days.


(Thomas) #36

Hi Tommaso,

today I saw that the german language files are online. I tried to run a test but the only thing mycroft does is to refresh and to list the openhab items found. Switching them does not work (“I don’t understand you”, “You might have to say that in a different way” …). Is there something I can do to debug the problem?

Best regards

McFly


(Tommaso) #37

Hi,
it looks like the problem it’s not related to the openHAB-skill. The answer you get it’s before the skill intend is recognized, so it’s not an answer coming from the skill but from the mycroft-core. Are you able to use other skill in German? I mean the standard ones (“what time is it”, “tell me a joke”, “what is the weather”, etc.).


(Thomas) #38

Hi Tommaso,
“What’s the time” in german leads to the answer, that Mycroft doesn’t understand me. Weather is reported without errors even if the translation is no proper german. The result of “Tell me a joke” is, that there are no jokes found. I guess there is no implementation of a german database for jokes in mycroft!?
I thought the error regarding openhab would be related to openhab because at least the skill refreshes items and lists them. If this is not the case, as you state, do you have an idea how to debug this?

Best regards


(Tommaso) #39

Hi,
you can try to open a ssh connection to your device (you can get the ip address asking “Hey Mycroft, what’s your IP address?”), after the connection is established you should wait to get the mycroft-cli-client (otherwise open the cli via command). Via mycroft-cli-client you can type commands and exclude a microphone issue. Check also the command syntax.