myOpen cannot connect

I have a problem when I try to setup my.openhab on my OpenHab 1.

I am running Mac OS X 10.11.6

  • I have copied the jar file into the add ons folder.
  • Logged into and created a UUID and a secret
  • Entered the UUID and secret in my /webapps/static folder
  • Setup the persistence (myopenhab.persist) in the configurations/persistance folder with these settings:
    Strategies {
    default = everyChange
    Items {
    • : strategy = everyChange
  • Updated java from to Java 8 Update 101
  • Tried running with sudo
  • Tried on 2 different Macs
  • openhag.cfg is setup as

My ip is

But I keep getting these errors in the log

18:55:50.051 [DEBUG] [.myopenhab.internal.MyOHClient:138 ] - Manager.EVENT_TRANSPORT
18:55:50.051 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS
18:55:55.140 [DEBUG] [.myopenhab.internal.MyOHClient:138 ] - Manager.EVENT_TRANSPORT
18:55:55.140 [DEBUG] [.myopenhab.internal.MyOHClient:143 ] - Transport.EVENT_REQUEST_HEADERS

and this error when an item is updated

18:55:45.508 [DEBUG] [.myopenhab.internal.MyOHClient:478 ] - No connection, Item update is not sent

I think it has something to do with java security, but can someone please point me in the right direction?

I have even tried with OpenHab2, but it with the same result.

Any help is appreciated.

Thanx in advance :slight_smile:

I am not quite sure, but isn’t it the other way round? Create the two numbers on your OH1 installation and copy them to my.openhab? Maybe you just have done it this way and only documented it the other way as I think it doesn’t work the other way…

Have you tried it with security OFF? Even if it’s not the desired way, but just to check if this is the problem.

Other than that I haven’t any suggestions…sorry…

I tried to delete the uuid and secret file and openhab created som new ones for me. I entered those at the webpage, but it is still the same result.

Finally figured it out…

I needed the Java SE Development Kit 8u101 to be installed, not only the client from

The SDK can be downloaded from

Hope it can help others from this “mistake”

Í want to reopen this topic, because have exactly the same issue, but did not get it solved with java update. Installed on raspberry jessie the jdk-8u151-linux-arm64-vfp-hflt.tar.gz.

Now java -version is reporting:

root@raspberrypi:/etc/openhab/configurations# java -version
java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) Client VM (build 25.151-b12, mixed mode)
root@raspberrypi:/etc/openhab/configurations# javac -version
javac 1.8.0_151

also after reboot I got still the connect problems. my openhab is not connected. The debug log is exactly the same as mentioned above.