MyOpenHab - Cannot change UUID and secret om my account

Hi OpenHAB community

I have just succesfully migrated my OH2.5 setup over to a OH3.3 setup which is all fine an dandy, but to put the icing on the cake i want to connect to so I can connect remotely… but for some odd reason i cannot change the UUID and secret once i’m logged into the… The fields are simply not there under my account???

I have seen two videos on youtube on how to do it but when i log into my the fields are missing and thus i cannot change the UUID and Sectret and thus get my new system “online”

Could somebody please take a look at that?

Best regards
M Klitgaard

I assume this is a typo and you meant “”.

Can you post a screenshot of your account page? It should look like this:

Hi Russ

Thanks for replying so fast

I have added a Screenshot of my account, as you can see it differs from yours

is this your/the master account ? Accounts can have different roles. The master account is being used to register an OH instance. Besides that a user’s role can be regular user.

Hi Wolfgang S

Sorry I’m getting a bit confused by your statement…

I have only ever had one account and that was able to receive a UUID and Secret. It is the first time that I have heard about a master Account?

Just thinking, even the master account should be able to accept a UUID and Secret?

Could you elaborate a bit more on the master account setup and how it works and possibly provide some links to where I can read about it

M Klitgaard

not even but only the master account seems to be able to do so.

My previous post is based on your feedback that the screenshots are different. Thus I logged in an detected the role menu in the users configuration.
Seaching for documentation I haven’t been able to find any on the page so far but I found this Enable Remote Access to a Local openHAB Instance

Ok So we can agree that my account is missing the feature of inserting a new UUID and Secret.

Also I have tried to delete my account, thinking I needed to start all over, but this is not possible either???

So I guess I need some help from some body who is able to control and program the “inner works” of web page in order to either fix my account or delete it so I can start all over.

Any body knows who I need to reach out to? or will the relevant people read this post?

I really would like to keep using the current mail for the account as it is used to inform me when various incidents occur

M Klitgaard

Go to the Users page: openHAB Cloud - Log in

You should see that your email address has the “master” role:

I don’t expect that this will have changed, since you weren’t aware of it, but it’s worth checking just in case.

You can try adding another email address as a master account and then log in with it. I’m just curious if that will be any different.

Hi Russ

Just tried to log-in on the link you provided to and I can not see the page you’re a showing (My Users) So i’m not able to add or see and overview of users on my account

As mentioned before i’m afraid there something wrong with my account, as mentioned earlier i cant even delete it to try to start all over…

M Klitgaard

I would assume that @rlkoshak or @digitaldan should be able to help with your account.

Just tried to log-in on the link you provided to and I can not see the page you’re a showing (My Users) So i’m not able to add or see and overview of users on my account

You are most likely using an account in myopenHAB with the role of “user” and not “master”. You can create multiple users when logged in with the original account used to register. So it’s likely you have another email address for the main master user.

If you PM me the email you are using to login i may be able to help.

Hi all

After Digital Dan gave the the right words then light dawned on med at I realised that i had another mail address as the Master account. (sorry Wolfgang & Russi did not pick that up on your reply’s even though you tried to point me in that direction as well)

After i figured out that i have a master mail account as well i could log into that one and set it all up

Now it is working as expected

Thanks to all who tried to help and assist me

M Klitgaard

1 Like

Not me. I can do some stuff with forum accounts but I’m just a plain old user of

1 Like