myopenHAB does not authorize Google Home

  • Platform information:
    • Hardware: Raspi 4 / 4 GB / 64 GB
    • OS: Raspberry Pi OS (latest)
    • Java Runtime Environment: OpenHAB running as docker container
    • openHAB version: 2.5.10
  • Issue of the topic: myopenHAB does not authorize Google Home

Hi Communitiy,

this is my first posting and as I see from browsing the messages people tend to work with passion on their problems for days, weeks or even months. Please forgive me if I am different.

I have spent a couple of days for getting my openHAB system up and running, with some shelly and some tamota things enabled, and everything works fine.

Actually, my problems started when I wanted to connect my setup to the voice control of Google Home.
This is what I did:

  • Set up a working openhab environment. Check. Did that. Even openHAB App on Android is up and running.
  • Took this guide /docs/ecosystem/google-assistant/ as a launchpad for connecting Google Home
  • Created an account at
  • Confirmed that myopenHAB and local installation interoperate. Everything fine. PaperUI and BasiUI work flawlessly.
  • Problems appeared when I tried to connect Google Voice Control with myopenHAB.
  • Followed the guide to setup the connection
  • At the point where I have to login to myopenHAB I do this and when I am asked to authorize Google I press “Allow”
  • The spinner appears telling me that myopenHAB and Google get linked. I even get a confirmation that both services are linked now … but thats a lie - they are not.
  • Neither can I see myopenHAB service in the “linked services” list nor can I assign any room to any item (like shown in the guide)
  • It simply behaves as if it was never linked.
  • Of course I can try to reinitiate the link (think I did this a douzen times today) but with no success.
  • Every new link-attempt adds up another line in myopenHAB/applications like this:

Today at 1:35 PM Google Google Assistant Voice Control

  • I also tried removing all previous links and start again, but with no success.

Actually, I am kind of lost now, and I would be gratful for any advice on how to debug whats going wrong, or - if I am totally wrong here - where I could place my request for help.
I think maybe a private installation of myopenHAB would help (with debugging), but if it is possible I would like to go the easy way and use

Thank you in advance for your help,

By the way: Just got blocked because a new user can only put two links in a post. I have exacly one. Will remove that now.

Before linking your OH account with GA did you have at least one Item with the Google Assistant metadata or tags? It used to be the case that the link request would be ignored and nothing happen unless there was at least one device for Google to discover.

After linking, did you ask GA to “synch devices”. That will cause Google to go and scan for new devices. Any time you add/remove the Item metadata to expose the Item to GA you need to sync for GA to pick up the changes.

1 Like

Hey Rich,

that was the perfect answer. Thank you very much.

I had issues with the metadata configuration and therefore no items were exposed and the service did not connect.

I fixed this, and now is runs.

Now moving on to advanced setup tasks.