Myopenhab & iOS notifications problem?

Same situation in here.

I just got my first notification randomly :smiling_face_with_three_hearts:

I don´t know if someone did something or not but my notifications started working again :slight_smile:

1 Like

Same here. Appears to be working now. Happy days.

Well, I’m glad to hear that at least. I didn’t do anything, so the problem cleared up on its own, I’m going to blame Apple for this one :slight_smile:

3 Likes

I am still not receiving notifications on my iOS device when they are sent via rules. Sending a message through myopenhab.org works, but not when using the “actions.NotificationAction.sendNotification” command in a rule.

notifications to Android devices works as expected.

  • Platform information:
    • Hardware: Gigabyte Brix MiniPC model GB-BXI7-5775R/MBHM87P-00 BIOS F2. 8GB RAM, 228GB HDD.
    • OS: Ubuntu 20.04 LTS
    • Java Runtime Environment: openjdk version “11.0.8” 2020-07-14 LTS
      OpenJDK Runtime Environment Zulu11.41+23-CA (build 11.0.8+10-LTS)
      OpenJDK 64-Bit Server VM Zulu11.41+23-CA (build 11.0.8+10-LTS, mixed mode)
    • openHAB version: 3.3 Stable

This is just a comment, not a request for support.

I’m looking to setup my own myopenhab-cloud instance and came across the error that the node app.js couldn’t find the file /certs/aps/AuthKey.p8.

As a complete newbie to this I didn’t have a clue, but now understand that that is a certificate from Apple Developer account, which to get I would need to buy a $99/year Apple Developer Account subscription just to generate.

Gee, thanks Apple! $99/year to generate a single certificate, as I have zero interest in actually making iPhone apps.

Hoping the myopenhab will work without a certificate, but I don’t know yet. I have seen threads where people have given it a blank cert file to get past the error.

That sounds strange to me. I don’t have an Apple Developer Account certificate and, thankfully, my iOS devices are once again getting notifications.

Hi together, since a few days I have a similar problem. When I send a message in a rule with the sendNotification() command, I can see the message in the Openhab app under Notification, but not as a message on the iPhone. When sending a message on myOpenHab, the message appears directly on the iPhone, but not in the Opehab app under Notification. This is very strange, as I have not changed anything on Openhab or the iPhone and the whole thing has worked for years.
Perhaps someone currently has the same problem and knows a solution.

Openhab 3.4.2 (Docker)
Iphone 15 / iOS 17.3
Openhab App 2.4.56

Anyone else have same problem again or it is only for me?

Today, everything start working again. :slight_smile:

1 Like

No notifications
iPhone 14 Pro, iOS 17.4.1
RPi 4

I think I cheered too early, now again no notifications.
I did get some notifications today, but not anymore.

Same here