Myopenhab items log not updating [Resolved]

Hi guys,

So when I run openhab on my myopenhab account it recognizes that the server becomes online as I can see it from the notifications tab. However, I don’t see any of my items on my myopenhab account even though they should be as I believe I have my persistence set up correctly. I created a myopenhab.persist file and configured it to be like the one on the tutorial page:

I currently run openhab on a windows 7 computer that has no wifi but is connected to the internet by a LAWN setup. Here are some lines from the openhab log on my local computer:

2016-10-28 15:12:05.125 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.3).
2016-10-28 15:12:05.895 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-10-28 15:12:06.201 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-10-28 15:12:08.234 [INFO ] [] - Started REST API at /rest
2016-10-28 15:12:15.628 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'demo.sitemap’
2016-10-28 15:12:15.779 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'WG_Test.sitemap’
2016-10-28 15:12:15.802 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'myopenhab.persist’
2016-10-28 15:12:15.826 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'demo.items’
2016-10-28 15:12:15.868 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'WG_Test.items’
2016-10-28 15:12:16.376 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/
2016-10-28 15:12:20.642 [INFO ] [] - Started HABmin REST API at /services/habmin
2016-10-28 15:12:25.862 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = COM7
2016-10-28 15:12:25.863 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-10-28 15:12:25.864 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-10-28 15:12:25.887 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-10-28 15:12:25.888 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms. Soft reset is false.
2016-10-28 15:12:25.890 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port COM7
2016-10-28 15:12:26.842 [ERROR] [b.z.i.protocol.ZWaveController] - Serial Error: Port COM7 does not exist
2016-10-28 15:12:30.868 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been shut down
2016-10-28 15:14:22.673 [INFO ] [.myopenhab.internal.MyOHClient] - Connected to my.openHAB service (UUID = *************************** local base URL = http://localhost:8080)
2016-10-28 15:16:07.143 [INFO ] [] - Stopped REST API

I also tried doing both persistence:default=myopenhab and persistence:default = rrd4j but that didn’t change anything as well.

Here is my WG_Test items file:
Group All1
Group TESTING (All1)

Number Temperature “Current Temp: [%.1f °C]” (TESTING){zwave=“3:command=sensor_multilevel,sensor_type=1,sensor_scale=0” }

Contact Sensor “Motion [MAP(]” (TESTING) { zwave=“3:command=sensor_binary,respond_to_basic=true” }

Any help for this issue would be appreciated. Also my start_debug isn’t quite working as well (as soon as I run it it closes automatically so any help for that as well is very much appreciated)

My security settings were also set to off but still no avail

Several users have reported being unable to get their Items to appear on my.openhab. I suspect (but have no special knowledge) that it is related to the other problems that my.openhab has been experiencing over the past few weeks.

In the meantime it is possible to send and receive REST API calls to and from your OH through my.openhab using the Maker channel in IFTTT. If not using IFTTT there really is no reason to post your Items to my.openhab.

Hey Rich,

Thanks for your response and your suggestion about the REST API. I’ll look into it as I do want to integrate OpenHAB with IFTTT. Hopefully this issue gets resolved soon.

Actually there has been a patch applied. There was a response on another thread.

Apparently the problem was indeed that there was too much traffic being generated by people persisting too many Items too rapidly for the servers to keep up. The developers have implemented throttling on persisting Items so now each account is only allowed 20 updates per minute.

In short, it should work now but make sure to only include Items that you really need to expose to IFTTT, set the strategy to everyChange rather than everyUpdate and make sure you stay under the 20 updates per minute.

It was never intended to support everyone sending all their Items to my.openhab but apparently that is how a lot of people have been using it.

Yes it is working now! Thanks so much for the information I’ll be sure to keep it under the 20 updates per minute.

Glad it finally works! Been on this issue for literally the past two weeks.


I already open an issue for OpenHAB2 because all items are persisting. See :

Anybody with a workaround ?



Hmmmm. That could explain the unexpected spike in traffic. I just looked at my list of Items on my.openhab and I see Items there that should not be and which have been updated fairly recently. My persist file is configured to only persist members of one Group and there were only three members of that group yet ALL of my items are present as well as my Things. And all of the Items have updated recently.

@belovictor, @digitaldan, it really looks like Issue 1126 might be the root cause of the problems with the spike in traffic.

If there is no way for us to control which Items are persisted and how (since we aren’t specifying them in our .persist files we can’t set the policy) throttling us to 20 updates a second still leaves us with a broken system.

I apologize if I’m saying stuff you already know but @digitaldan’s posting here makes me think the connection between the two may not have been made.

Sorry for the very late reply @rlkoshak , you are correct that 1126 is a problem, it’s on the list of things to fix! Thanks for your help!