myopenHAB Maintenance 2/19/2022 10:45 PM UTC (DONE)

(Service Complete) HI, on Feb 19 @ 10:45 PM UTC Feb 20 @ 4:00 PM UTC (8 am PST) I will be performing an upgrade of our cloud service. This will address a race condition under load where connections can get in zombie state and need to be reconnected.


Actually, due to time issues tomorrow, i’m going to go ahead and do the upgrade now, apologies for the last min notice.

This took much longer then i anticipated, but is done now. The service may be slow to get going. If your openHAB did not reconnect, you can restart the binding by going to the cloud settings in the MainUI and click “save” (even though you did not change anything). Reconnect issues were fixed in versions 3.4.2 and later and should not need assistance to reconnect.


Hi I’m having problem reconeccting my device shows online but no notifications from DSL rules gets to my phone. I can control my items. Running 3.4.1

16:19:02.476 [INFO ] [.io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
16:19:02.477 [WARN ] [.io.openhabcloud.internal.CloudClient] - Socket.IO disconnected: io client disconnect
16:19:02.478 [INFO ] [.io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = 05...c5, base URL = http://localhost:8080)
16:19:02.850 [INFO ] [.io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = 05...c5, base URL = http://localhost:8080)

This is most likely unrelated to the upgrade. If you can control your items through the cloud (i’m assuming thats what you meant), then your connection if valid. You might want to try launching your mobile app (you did not mention if your phone is Android or IOS ) so it can register again for notifications. Both platforms can eventually loose their registrations over time.

1 Like

Same issue here on 2.15, No notifcations from Rules after several restarts

What is “2.15” ? What kind of device (android / IOS) ? What type of notification (sendBroadcastNotification, sendNotification), are there any messages in your logs ?

Its really hard to help without any details.

I am having trouble connecting Google to MyOpenHAB.
In Google Home, choosing OpenHab as the account I’d like to connect, and then trying to log on - I can a) either successfully log in, seeing the “Your openHAB is online. Click here to access your openHAB’s dashboard” message or
b) get an “Internal Server error”.
However, I think the OAUTH2 handles are never transferred to Google.
Could you check to see whether this is an issue with my setup, or whether it has something to do with the maintenance?

Things already tried: successfully destroyed and recreated my account at MyOpenHab.
Cleaned cache as well as user data of Google’s Home app on my android device.
Uninstalled FireFox on my android device to see whether it was a FireFox issue → nope, Chrome behaves the same.
Any help is greatly appreciated!

Hmm, this would seem to be an issue with the last release and some routing clean up i did, i’ll take a look now.

1 Like

Hello Dan,
it seems to me that sendBroadcastNotification stopped working.
It worked yesterday but not today. To be honest I made a restart between so it could be on my side.
I’ve run a test this afternoon with this condition:
if (GatePosition.state == OPEN) {
sendBroadcastNotification(“Gate open. " + LocalDateTime.state.format(”%1$tk:%1$tM:%1$tS"))
sendNotification(“…”, “Gate open. " + LocalDateTime.state.format(”%1$tk:%1$tM:%1$tS"))
The second sendNotification fired only to the addressed user.
Cloud is connected. And I don’t think that this would be ios related.
Can you please verify that BroadcastNotification works? If works I must check my system deeper. Thank you.

1 Like

Sorry for the lack of details. Here is my setup which is not working properly since yesterday evening (I guess). The last sendBroadcastNotification was received on 19.02.2023 23:03 GER time

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.2 (4GB RAM); SDD WDC_WDS500G1R0B-68A4Z0
    • OS: Raspbian GNU/Linux 10 (buster)
    • Java Runtime Environment: openjdk version “11.0.11” 2021-04-20 LTS
    • openHAB version: openHAB 2.5.12 Release Build

Four android devices are involved and all are affected running openHAB version 2.23.0
I noticed that sendNotification are working properly where sendBroadcastNotification are not received at all.

Here is a test rule which is working

rule "System Testnachricht"
  Item System_TestMessage changed to ON
  sendNotification("", "Testnachricht", "smiley", "Test")
  logInfo("System", "Testnachricht gesendet")


2023-02-20 19:20:04.449 [ome.event.ItemCommandEvent] - Item 'System_TestMessage' received command ON
2023-02-20 19:20:04.452 [INFO ] [clipse.smarthome.model.script.System] - Testnachricht gesendet

I received the message sucessfully. With sendBroadcastNotification I dont get any message, the logs does not provide any error messages.

Where else can I look? Thanks for your support


I was indeed meaning the remote control of items via cloud sevice. However the notifications isn’t present in myooenhab web ui either. Last known notification is 6pm yesterday sweden timezone +0100.

If theres something else strange I dont know. But will keep trying fix it with reboots and try to find a clue.

Thanks Markus, that detail really helps, i honestly don’t test sendBroadcastNotification often since its so closely related to sendNotification, so likely i missed something there, i’ll look.


No worries, I am glad you gave the hint with with the different types. I did not assume that there is a difference whether notifications work or not :slight_smile: I am using both types a lot in our environtment (family stuff is sendBroadcastNotification and sendNotification is only used for “admin purposes” if something important goes offline) - Let me know if I should check something again on my site and thanks for your support!

Hi @ianoxian can you try again? There was a small issue in a template include that was causing the issue, i was able to do a quick hot deploy .

1 Like

Hi Dan,

Thank you for take care of the problem
I’ve got the exact same behavior: notifications to user work, broadcast notifications don’t. OH 3.4 @rpi 4(2GB) with USB SSD/ Android App 3.2
but i saw in the account, that the notifications are synchron with the app, so I think it’s independent from App…

All the Best :vulcan_salute:t2: