MyOpenhab Not receiving Pushnotifications

I am trying to add some notifications to my rules, which seems simple enough, but unfortunately they don’t get sent to my phone, and they don’t showup in the notification page…

  • I have myopenhab configured and use the openhab2 cloudconnector
  • I can remotely control my lights etc… through the openhab app
  • When sending a test pushmessage from backend I do receive the message on my phone

The functions I try in my openhab rule:

logInfo("motion_detect_rule", "Tty send message")
sendNotification("", "Motion detected")
sendBroadcastNotification("Motion detected")

Only the logInfo seems to work in the rule…

I did notice when looking in the notifications tab, that the last time I received an “offline” & “online” pushmessage is thursday, although I had my raspberry disconnected for a few minutes today…

If anyone has a clue please let me know.

Same behavior here since last week Thursday.
BTW, if you log in to your account at und you send a notification from there, it will arrive to your mobile phone without any problem. I guess the issue lies in the link between the cloud and the openhab instance.

@mrthomaslang: could yo please verify that this behavior is working for you?

Hi there, yes @Alexus1211 that’s correct, I also mentioned it in my starting post :wink: I can send push messages through the backend, (the “Send a message to this device” option)

But other push notifications are not being received. I figured it is probably a problem with since I haven’t received online / offline push messages since thursday… :frowning: I hope someone can help out.

Same here, Push notificaton from do arrrive on the mobile device, but notifications from the openhab instance seems not to get delivered to, they do not show up in the notifications list.
For me it stopped working on June 19th.

still no push notifications… :frowning:

Works here again since Sunday. I had to replace my ZWave USB stick, rebuild my Zwave network and restart OpenHAB. Since then I’m getting again notifications. No clue why, unfortunately.

Also was not receiving notifications and then updated to latest snapshot, restarted OH on Monday and started getting them again as well.

Thanks all, ran the update and upgrade from openhab-config, and everything is working now! :slight_smile:

can you please explain? how can i get it working again? i ran upgrade via apt-get. thx

you need to run openhab-config in terminal, and choose upgrade from there.

i got it! thx

1 Like

I’ve got the same issue and for me nothing of above works, do I need any addon or *.cfg changes?
same as @Thomas_Link , how do I diagnose the link between openhab and myopenhabcloud?

For me this Problem still exists. I can send Messages from the myopenhab backend, but with my rules notifications don´t arrive at my mobile. Upgrade was made, so anyone can help me?

Try to delete uuid and secret, reboot and introduce new details to website

Ok. Where should I delete the uuid and secret? On my openhabian-system? I Think yes. I will try out later when I reach home. Thanks in advance

This was not the sollution. MAybe there is an Problem with my rule. Is there an easy way to check if the notification function works? Maybe an example rule?

when I had this problem all I’ve done is delete uuid and secret from openHAB-share then reboot Pi then check the values of the new generated uuid and secret, introduce on then maybe reboot Pi again.
check from if your devices receives messages sent from there.
If this does not solve the problem then maybe someone with more experience can help, pretty sure it’s something silly