Myopenhab offline

Hello guys.

I have openhab 1.8.3 installed on a Pi Zero with java version 1.8.0_121
I’ve also followed the instructions for the myopenhab connector by pasting the whole thing at the bottom of the openhab.cfg file but myopenhab still doesn’t connect.
I’ve reinstalled a few times and check UUID and secret also.

If there’s anything more I should do, please let me know. Thank you.

Did you click on the confirmation email that was sent to you when you first signed up for the account on myopenhab.org?

Are you seeing anything in the logs?

By default there really isn’t anything that needs to be configured to connect. What are you configs that you copied into your cfg?

I copied the text at the bottom of this page into the cfg :https://github.com/openhab/openhab1-addons/wiki/openHAB-Cloud-Connector

Logs just say "item update not sent"
I don’t think I saw any other errors apart from this

I have clicked on the link already. I even deleted my account and did it again and reinstalled openhab too.

What about my first question. Did you click on the link in your confirmation email that was sent to you when you signed up for your account?

Yes i did

Please post your OH startup logs. In particular we need to see anything printed by the connector.

openhab.xml (247.4 KB)

here are the logs

There are no relevant errors and it shows that the binding it initializing but I don’t see either a connection successful or a connection failed. There are lots of errors indicating that the connection is not established when it tries to upload Item event state changes.

You can try uninstalling and reinstalling it to see if that makes a difference. I’m not sure what else it could be.

Ah I’ve tried that already. Guess it’s time to do it all over again .

When you reinstall the binding, make sure to delete your uuid and secret file before reinstalling them. It probably isn’t needed but just in case…

I’ve now reinstalled it aaaand It’s still offline.

Myopenhab has been down for at least several hours today. I can’t log in to the website.

http://status.openhab.org/

Site reports All Systems Operational; however my browser returns:
“504 Gateway Time-out nginx/1.10.0 (Ubuntu)” from https://myopenhab.org/

http://www.myopenhab.org/ main page is operational, but that’s it.

The service appears to be back up now. It seems that the status site cannot be trusted to be accurate.

I don’t really know what else to try. I’openhab.xml (352.9 KB)
ve looked at so many tutorials for myopenhab and mqtt and neither work.

  1. Are you using the Cloud Connector add-on? You should be seeing log statements like this:

    2017-01-28 12:43:40.441 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = e47a83fc-7b30-4d20-ac24-8dc8c8102c22, base URL = http://localhost:8080)

    Note the statement is coming from openhabcloud, not MyOpenhab

  2. Are you running with the latest Oracle Java, at least version 1.8.0_111.

  3. MQTT is completely independent from the MyOpenhab Cloud Connector. Have you also installed the MQTT Action? If so there is currently a bug that prevents the MQTT binding from working when the MQTT Action is also installed.

Nope, I have the cloud connector in my cfg but I’m not seeing anything related to it in the logs.

No, I only have mqtt binding installed.

  • apparently i didn’t follow the tutorials as closely as I should’ve in my rush to get this done. I’ve installed the cloud connector, everything works now. thank you

Hi,
I got the same issue than you. Could I know what was your error? which tutorial did you follow?
Thanks in advance