Myopenhab.org items not showing

This is definitely a grey area in the documentation that is catching up a few people (now that exposed items don’t show up in myopenhab).

1 Like

Yes and it makes me wonder how much load on the myopenhab server is from people exposing stuff that is not needed to be. Can someone volunteer to update the docs? @Andrew_Rowe? Is there any reason other than IFTTT that needs the items exposed, or is it the only reason currently?

that is correct, I use the cloud connector and have nothing exposed

Let me track down the right repo and I’ll see if I can get a pr going

1 Like

OK… I found what it was I was thinking. Here is a recent issue raised on the hueemulation binding which indicates something changed and all items not tagged as [internal] get exposed
@5iver Scott, can you read thru this thread quickly and see if this issue is causing high load on servers?
@digitaldan Dan, are you aware of following issue and could it be causing problems with server load?

(original post due to caffeine levels not yet up)
Sorry for not yet fully absorbing what is going on but I swear there was recent talk where something changed and all items which are not tagged [ignore] or something like that are automatically exposed or something, I think it’s a bug. Maybe this is wreaking havoc with servers, have the servers been experiencing high load? Off to dig around a little…

something is up… the other thread is about ifttt integration

2 Likes

This issue will only affect people using the snapshots (soon 2.5M2, if this is not deemed critical), and only after hueemulation is fixes so that it can discover devices again. Also, exposed to Alexa does not mean exposed to myopenhab.org, so I can’t see it being related. TMK, exposed to myopenhab.org does expose the devices to the Alexa skill.

@digitaldan will know best and might also be able to look into the hueemulation issues, which it looks like David is no longer supporting (but officially still listed as a codeowner).

1 Like

yeah that does seem to be the case if you read a few of his comments on git
example comment click the link

1 Like

that is what I did from the beginning. I just gave it another try with a test item.

Switch Testitem "Testswitch" [ "Lighting" ]

I changed the state of the item. But still no Item in myopenhab.org.

It will not show up in myopenhab and does not need to. Just say ‘Alexa discover’ and see these links.

https://www.openhab.org/docs/ecosystem/alexa/

https://www.mksmarthouse.com/amazon-echo

I think a clarification is needed. Alexa and Google Assistant do not need items to be exposed via PaperUI, or to show up in the items list in myopenhab. They just need to be tagged properly with the cloud connector working, and then you can discover them.

Items only need to be exposed in PaperUI for IFTTT (and hue emulation?). However, this currently doesn’t work as it was overloading myopenhab.org. @DanE, you’re following the documentation, but at the moment the documentation is cause for confusion.

The way the documentation is written, it is implied that you have to expose items via PaperUI for them to work in Alexa and Google Assistant, but this is not required or necessary. That was the root of the side conversation we had, but I can see how that might not have given you any clarity.

So as @matt1 says, you should be ready to discover your devices with Alexa and have them start working! And if you do have any devices exposed, you can de-expose them since it’s not doing anything useful.

1 Like

Ok. Sorry for missunderstanding. I always thought in order to use items with alexa I need to see them in the items list first.

So far so good.

So I just started the discover in the alexa app. But unfortunately there are no new items found.

If I lookup https://myopenhab.org/rest/items I do find my Testitem:

{"link":"https://myopenhab.org/rest/items/Testitem","state":"OFF","editable":false,"type":"Switch","name":"Testitem","label":"Testswitch","tags":["Lighting"],"groupNames":[]}

Am I missing something?

It doesnt seem to be a problem with your item.
I dont know for sure, cause I use Google Assistant, (not Alexa). I can add the same switch and afterwards ask Google to sync my devices, then the switch appear just fine in the Google app… But this is not the same as showing the item for myopenhab.org (just to make sure it´s not what your trying to).

Do your log show anything?.. Maybe try create a sitemap and use BasicUI to make sure the switch is working. Or use the controlpanel inside PaperUI. It might show a problem, if there is one which is not visible in the item itself. (sometimes using items text files, there can be some none visible caracters inside which screw up the items file. The log would/should tell you if there is a problem).

When ever I create a new switch/function or any changes, (rules too), I always create the item/function in a sitemap to make sure it´s working as it´s suppose to, even if I dont actually need it visible.
If I need it visible/control via Google Assistant, I add the tag afterwards and then sync my devices. I have done it about a zillion times by now and can probably do it blindfolded. It works every time, except when there are issues with the cloud/myopenhab server etc.

I do have the switch on a sitemap in order to change the state. And the log for this items file is without any errors.

Thats very odd, as I see nothing in the item which should prevent it from working. I have several items like that (used as proxy items). And they all work just fine…

Suggestions:
Try change the tag to [ “Switchable” ] just to see if it makes any difference.
Make sure your ‘Testitem’ isn´t already exsisting.
Try make a new item, (with an item name which is abnormal. Like Testitem001).
Remember label and tag.
Remember to “sync” your devices with Alexa.

Perhaps try several items like this:

Switch  Testitem001   "Testswitch one [%s]"    <switch>   [ "Lighting" ]
Switch  Testitem002   "Testswitch two [%s]"    <switch>   [ "Switchable" ]

Etc…

I can give it a go tonight with a new item, But I would be very surprised if it doesnt work.

So I added two new items:

Switch  Testitem001   "Testswitch one [%s]"    <switch>   [ "Lighting" ]
Switch  Testitem002   "Testswitch two [%s]"    <switch>   [ "Switchable" ]

I changed the state of both items. Then I started the discover in the alexa app. No new items found!

Very weird!

It is :frowning: I have no idea or anymore suggestions. I will give it a go tonight when I get home. Maybe there is a general issue atm…

It would be good to know if anyone else using Alexa suffer the same problems? Like I said, I use Google Assistant. So if there is an issue with Alexa, I would never notice.

I just tried with the exact same items as the example… After adding to an items file, I made a “sync my devices” to my Google Home mini. A coupple of seconds after… This:
(notice the devices at the bottom of my Google Home app, the two items Testswitch one and Testswitch two).

It works fine.
So either something is wrong in your settings, or there is a Alexa issue.

Nope, still working fine as usual.

Make sure your Alexa Skill is authorized:

grafik

I think a space is needed bitwin the brackets and the semi column ex [ “Switchable” ] try that it worked for me! Also the tag goes before the { bla bla } check the syntax

If he uses the example I showed, without adding anything else, he should be good to go.

1 Like