items not showing

It will not show up in myopenhab and does not need to. Just say ‘Alexa discover’ and see these links.

I think a clarification is needed. Alexa and Google Assistant do not need items to be exposed via PaperUI, or to show up in the items list in myopenhab. They just need to be tagged properly with the cloud connector working, and then you can discover them.

Items only need to be exposed in PaperUI for IFTTT (and hue emulation?). However, this currently doesn’t work as it was overloading @DanE, you’re following the documentation, but at the moment the documentation is cause for confusion.

The way the documentation is written, it is implied that you have to expose items via PaperUI for them to work in Alexa and Google Assistant, but this is not required or necessary. That was the root of the side conversation we had, but I can see how that might not have given you any clarity.

So as @matt1 says, you should be ready to discover your devices with Alexa and have them start working! And if you do have any devices exposed, you can de-expose them since it’s not doing anything useful.

1 Like

Ok. Sorry for missunderstanding. I always thought in order to use items with alexa I need to see them in the items list first.

So far so good.

So I just started the discover in the alexa app. But unfortunately there are no new items found.

If I lookup I do find my Testitem:


Am I missing something?

It doesnt seem to be a problem with your item.
I dont know for sure, cause I use Google Assistant, (not Alexa). I can add the same switch and afterwards ask Google to sync my devices, then the switch appear just fine in the Google app… But this is not the same as showing the item for (just to make sure it´s not what your trying to).

Do your log show anything?.. Maybe try create a sitemap and use BasicUI to make sure the switch is working. Or use the controlpanel inside PaperUI. It might show a problem, if there is one which is not visible in the item itself. (sometimes using items text files, there can be some none visible caracters inside which screw up the items file. The log would/should tell you if there is a problem).

When ever I create a new switch/function or any changes, (rules too), I always create the item/function in a sitemap to make sure it´s working as it´s suppose to, even if I dont actually need it visible.
If I need it visible/control via Google Assistant, I add the tag afterwards and then sync my devices. I have done it about a zillion times by now and can probably do it blindfolded. It works every time, except when there are issues with the cloud/myopenhab server etc.

I do have the switch on a sitemap in order to change the state. And the log for this items file is without any errors.

Thats very odd, as I see nothing in the item which should prevent it from working. I have several items like that (used as proxy items). And they all work just fine…

Try change the tag to [ “Switchable” ] just to see if it makes any difference.
Make sure your ‘Testitem’ isn´t already exsisting.
Try make a new item, (with an item name which is abnormal. Like Testitem001).
Remember label and tag.
Remember to “sync” your devices with Alexa.

Perhaps try several items like this:

Switch  Testitem001   "Testswitch one [%s]"    <switch>   [ "Lighting" ]
Switch  Testitem002   "Testswitch two [%s]"    <switch>   [ "Switchable" ]


I can give it a go tonight with a new item, But I would be very surprised if it doesnt work.

So I added two new items:

Switch  Testitem001   "Testswitch one [%s]"    <switch>   [ "Lighting" ]
Switch  Testitem002   "Testswitch two [%s]"    <switch>   [ "Switchable" ]

I changed the state of both items. Then I started the discover in the alexa app. No new items found!

Very weird!

It is :frowning: I have no idea or anymore suggestions. I will give it a go tonight when I get home. Maybe there is a general issue atm…

It would be good to know if anyone else using Alexa suffer the same problems? Like I said, I use Google Assistant. So if there is an issue with Alexa, I would never notice.

I just tried with the exact same items as the example… After adding to an items file, I made a “sync my devices” to my Google Home mini. A coupple of seconds after… This:
(notice the devices at the bottom of my Google Home app, the two items Testswitch one and Testswitch two).

It works fine.
So either something is wrong in your settings, or there is a Alexa issue.

Nope, still working fine as usual.

Make sure your Alexa Skill is authorized:


I think a space is needed bitwin the brackets and the semi column ex [ “Switchable” ] try that it worked for me! Also the tag goes before the { bla bla } check the syntax

If he uses the example I showed, without adding anything else, he should be good to go.

1 Like

Yep i can confirm this once you tag the item the right way it will show on alexa after making a search. also make sure your openhabcloud is online.

1 Like

here is an example working NOW on my alexa from sony binding, hope this can help you.

Switch BraviaPower “Power” [ “Switchable” ] {channel=“sony:simpleip:xxxxx:power”}

Unfortunately still nothing worked. I deleted all Testitems and reinstalled. I deleted the openhab skill on alexa and reinstalled. I made sure that they are linked in the And still, if i search for new items with alexa, I cannot find any new items. The show all my testdevices. They are labled and taged.

Crazy! :frowning:

It has to be an Alexa issue/config issue at your end, somehow… I´m sorry I´m not able to help you on that part.

where do you have your items through on the conf folder through *.items or through the jasondb folder?

all the items that you want to expose to alexa have to appear tagged like this!
“BraviaInput”,“label”:“Input”,“tags”:[“Switchable”] on the

i did it like this and it worked for me!!!

how did you tagged your itmes?

by the way for alexa you dont need to fo this, “I made sure that they are linked in the” this is only for IFTTT and is not working at the moment for alexa fust to tagg your items

Hi Kim,

Maybe you may be able to offer some clarity on this one task that i have been searching for some time now.

I would like to use Alex to switch the input sources from HDMI2 to HDMI4 this how it looks my items file:

String BraviaInput “Input” [ “Switchable” ] {channel=“sony:simpleip:xcxcxcxc:input”}

this is my sitemap file:

Switch item=BraviaInput label="Input"icon=“receiver” mappings=[HDMI2=“HDMI2” , HDMI4=“HDMI4”]
and on basicui/app i can switch with no problem from input sources.


what do i have to do or add on my items file “which is a string type” so that Alexa can send command through openhab ??

Thanks for your help