notifications not working

Hi OH Community,
I have some rules which sends notifications using “sendBroadcastNotification(“Hello World!”)” which worked fine for months. But since 2 weeks no notifications coming to my iOS device or on the android phone of my girlfriend. Rules and Logs are fine. Connection to is also working without problems except notifications, I can’t see them in the WebUI either.
I’m using OH2.1 stable on RPI3.

Does anybody have an idea how to track down my problem? :confused:

Thanks in advance!

Can you Show us some rules?

Sure, here is a simple example:

rule "Washingmachine Notifications"
        Item Washingmachine_OpState changed
        if (Washingmachine_OpState.state == MODE_FINISHED) {
                logInfo(filename, "Washingmachine finished!")
                sendBroadcastNotification("Waschmaschine ist fertig!")

Log output:

2017-11-06 20:05:46.452 [INFO ] [model.script.household-devices.rules] - Washingmachine finished!

I haven’t changed anything and this example worked flawlessly before.

Any further tipps?

I tried to force send a notification by using a simple script file but I can’t execute this.


sendNotification("", "Test Notification!")
logInfo("Notify", "Notification submitted")

Karaf console:

openhab> smarthome:> notify
 ___ notify
   Cannot make a static reference to the non-static method notify from the type __synthetic0Script; line 1, column 0, length 6
openhab> smarthome:> notify.script
 ___ notify. ___ script
   1. The method or field script is undefined for the type void; line 1, column 7, length 6
   2. Cannot make a static reference to the non-static method notify from the type __synthetic0Script; line 1, column 0, length 6
   3. Type mismatch: type void is not applicable at this location; line 1, column 0, length 6
openhab> smarthome:> "notify"
 ___ notify
   Cannot make a static reference to the non-static method notify from the type __synthetic0Script; line 1, column 0, length 6
openhab> smarthome:>"notify"
openhab> smarthome:>"notify.script"

No notification message or log message, the script does not seem to be executed…

How do I call scripts properly?

I was able to fix my problem, it looks like a bug to me.
About 2 weeks ago, my RPI3 Wifi connection was unreliable, so I plugged in my ethernet cable and restarted my RPI.
Since then I haven’t received any notifications. I changed the cloudconnector binding to DEBUG loglevel and could see the following message:

2017-11-14 10:43:50.652 [DEBUG] [] - sending broadcast notification 'Nobody is at home - PresenceCheck' to all users
2017-11-14 10:43:50.654 [DEBUG] [o.openhabcloud.internal.CloudService] - Sending broadcast message 'Nobody is at home - PresenceCheck' to all users
2017-11-14 10:43:50.656 [DEBUG] [io.openhabcloud.internal.CloudClient] - No connection, notification is not sent

I realized the following message at the beginning of the log:

2017-11-14 09:13:15.890 [WARN ] [] - Found multiple local interfaces - ignoring 192.168.X.X
2017-11-14 09:13:15.892 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at http://192.168.X.X:8080
2017-11-14 09:13:15.894 [WARN ] [] - Found multiple local interfaces - ignoring 192.168.X.X
2017-11-14 09:13:15.899 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at https://192.168.X.X:8443

I shutdown my Wifi interface and restarted OH and now notifications coming to my phone!
So there seems to be a problem if you have multiple network interfaces…
Ethernet and Wifi were both connected to the same router.

I just use ethernet now.

I have exactly the same problem - notifications works well for a certain amount of time and then stop.

Here is a rule I use for testing

rule "test notification"
	Item notification_test changed from OFF to ON
	sendCommand(notification_test, OFF)

At the moment this is working fine, but in a day or two notifications will randomly stop

I am relatively new to OpenHab2 so I’m not sure how to get the Cloud Connector into Debug logging mode (currently in the log viewer I only see the rule firing, nothing from the Cloud Connector).

Please could someone provide me with some basic instructions for getting the cloud connector into DEBUG log level?


start the console:

ssh -p 8101 openhab@localhost


log:set DEBUG

1 Like

seems that “” saves the track when the sendNotification happened, however I still do not get it in my phone(app).
If I try via directly from a cloud - I get the message instantly, if I trigger a rule (which was surelly working fine 3-4 days before) - I get nothing.

DEBUG shows nothing to me, at least no error messages etc, no recent modifications in code etc.

does anyone know about ongoing issues?


I’m seeing the exact same problems, notifications stopped and came back.

To confirm, this started to work again.
I’d believe this was not related to OH2 internal (your) configuration at all, rather Openhab Cloud service was not functioning for a while.

p.s. I haven’t changed anything, just checket and now started to receive all my notifications once rules are trigered.

Ok, this is happening for me again - and I would think that if it was MyOpenHab other people would notice - having put it into DEBUG mode I see:

2017-12-06 11:43:54.824 [DEBUG] [] - sending broadcast notification 'Test' to all users
2017-12-06 11:43:54.826 [DEBUG] [o.openhabcloud.internal.CloudService] - Sending broadcast message 'Test' to all users
2017-12-06 11:43:54.827 [DEBUG] [io.openhabcloud.internal.CloudClient] - No connection, notification is not sent

However I am actually firing the rule using a Switch on my sitemap, and I’m accessing this via Myopenhab, so from reading this post and others it looks like three things have been suggested:

  1. It’s a problem on the MyOpenHab side - seems unlikely as it happens a lot and at times when other people don’t mention it (that and i’m connected to MyOpenHab)

  2. It’s down to having multiple interfaces. My Pi has 3 NICs but only one is connected (eth0 has no cable, wlan0 is down as it’s flakey, only wlan1 is actually connected):

    eth0 Link encap:Ethernet HWaddr b8:xx:eb:xx:e4:45
    inet6 addr: fe80::b41f:6c65:da1a:2e66/64 Scope:Link
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:52821 errors:0 dropped:0 overruns:0 frame:0
    TX packets:52821 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:6398901 (6.1 MiB) TX bytes:6398901 (6.1 MiB)

    wlan1 Link encap:Ethernet HWaddr 00:xx:ef:90:xx:xx
    inet addr: Bcast: Mask:
    inet6 addr: fd00::1:e824:3eb:cc3d:fdbb/64 Scope:Global
    inet6 addr: fe80::b2cd:9264:90d5:9e1e/64 Scope:Link
    RX packets:2723074 errors:0 dropped:28844 overruns:0 frame:0
    TX packets:2459749 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:2636114790 (2.4 GiB) TX bytes:1252209795 (1.1 GiB)

This does not look like OpenHab could be using the wrong NIC?

  1. It’s down to a corrupted SD card as mentioned in another post (Notifications not working?)

Not quite sure how to diagnose this but I’ve ordered a new SD card anyway as my current one is very old. I’ll clone the existing to the new and see if the problems magically disappears

Any more suggestions of diagnoses I can do?

My notifications haven’t been working since December 7th. I think there is an issue with the service as I didn’t change anything in my configuration to cause this to happen.

I doubt it’s the SD card, I can say for sure that in my case the same problem disappear after restart. I’m unable to determine how it starts though, seems random. It may be caused by a network problem, but for sure it doesn’t recover without a reboot.

Anyone can help ?

I’ve just noticed my notifications are also not working. Last time I got notifications was with openHAB 2.1 and the previous version of openHAB on Android. I updated both a few weeks back but didn’t check if notifications were working. No configuration changes in my openhab apart from the version updates.

Under I see notifications are coming thru but not showing up on the phone. I’ve reset the Android app and restarted my openhab. Log shows me notification and as they show up in it can’t be a problem my local system. I’d like to try with the older Android app which I don’t have.

So for me I think its the Android app. I must confess I’ve never spent any time on so is there something else I could check?

In the Android app under notifications its blank, should this contain a list like under

**** FIXED NOW ***
Added a dummy master account in and deleted previous account. Recreated the master account name I wanted and deleted dummy. Restarted openhab (important) and all ok now.

I have also been having the same problem since I upgraded the Android app to version 2.0.0, and openHAB to version 2.2.
My solution is to restart the openHAB 2 service, but some time later it stops sending notifications again.

Hello again. In my case I only have one RaspBerry Pi 3 with WLAN disabled, so I only have one network interface connected, but I had two IPs assigned to the same interface (main IP for Internet Access, secondary IP for VPN uses only). In the PaperUI system configuration I had specified the main IP to be used for the openHAB services.
Two days ago I temporaly removed secondary IP from the network interface, as test, and for now it seems that the problem of notifications has been solved. I’ll tell you next days. Greetings.

No way. Friday second february, 22:26 UTC+1 I received “openHAB is offline” notification. I restarted OpenHAB 2 service by SSH console and I received “openHAB is online” notification. No more notification received since that moment. I will restart service again trying to restore notifications function. Removing secondary IP does not seem to have solved anything. :-/

After several tests, I have come to the conclusion that the problem occurs when there is an interruption in my Internet connection, which is not stable lately. It seems that the cloud connector loses connectivity, and when it recovers it does not reestablish the ability to send notifications, which forces me to restart the openHAB 2 service so that it works again.

Latest news: I’ve been receiving notifications for more than 20 days without any problems. No change has been made.

Hi all,

With this Androind binding, can you then specify which items you want to get notifications from?
Like if one of My Sensors are triggered, then it will do a push message on my Android phone?