myopenHAB Service Update tonight, Sunday 8 PM EST / Monday 1 AM CET

I will be pushing out an update to myopenHAB related to migrating from a deprecated version of the Google messaging platform. There will be a temporary interruption in the proxy service as openHAB instances reconnect during the process restarts.


I hope
Is not connected.

@digitaldan how did the update go? I´m experience very slow connection to cloud today.

Today i couldn’t reach my openhab installation nor from alexa nor from google assistant.
-i’ve restarted the router
-i’ve changed item states
-i’ve restarted the openhab service
-i’ve restarted the raspi
-i’ve disconnnecteds the accounts from the 2 voice assitants
tried to go through discovery again, and it does let me do the OAuth procedure to the openhab cloud, but nor alexa nor google home can find any devices within the OH skill/service…

what should i do O.O?

EDIT: I should add that on the web page everything seems ok: exposed items are discovered, their statuses are updated, i’ve made no change to items files or Json items.
And if i go through OAuth procedure for a new instance of Alexa or Google Home, they appear in the Applications section of Myopenhab.
But neither of the 2 voice assistants see my devices(all z-wave)

Wait untill Dan has responed. I´m having simular problems here. But there is no reason to do all kind of changes, if/when the issue is around the cloud server. I think the update has created an issue with the cloud.

My myopenhab was re-connecting every few minutes (from 2:00 AM til 3:39 AM in CENTRAL EUROPE, GERMANY)


But since 3:39 AM it is running continuously! :slight_smile:

Yeah, thats myopenhab…
But can you access you´re openhab through the cloud?
Right now, as I´m writing this. I cant access my openhab server through the cloud (ie myopenhab). But myopenhab does respond just fine and I can log in as well. From there, no respons.

same here, although it shows “Online”, I can’t connect and get a timeout when trying to access the dashboard.


YES, I am able to open PaperUI, Habmin, ClassicUI, and also seeing Notifications.

I can switch items. But don’t know if correspondig LightBulbs were switched on/off, because I’m not at home… :wink:

z-wave network viewer is also running:


I also can access through HabDroid (=OpenHAB Android APP)

Dashboard is running:


Same issue here, “504 Gateway Time-out” when trying to access dashboard via myopenhab. It does open and let me log in though. I can’t access items via RESTful API and Tasker too. Mobile application also not working outside of home network.

Best regards,

I’m looking into this now, I restarted services around 2 am CET time, and it can take a while for traffic to reconnect. By 3 CET it looked normal, and my testing showed web and proxy connections were working. But right now, the service is very slow, and is probably not useable for many. i’m looking into why that is now. All servers look normal, so it’s not completely obvious what the issue is.


I had the same issues reported above (Alexa and Android app not reaching my instance).
I restarted my local openhab instance and now everything works again.

From my log:

2019-03-18 03:23:36.300 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = xxxx, base URL = http://localhost:8080)
2019-03-18 03:24:16.954 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = xxxx, base URL = http://localhost:8080)
2019-03-18 03:24:27.420 [WARN ] [okhttp3.OkHttpClient                ] - A connection to was leaked. Did you forget to close a response body?
2019-03-18 03:28:01.211 [WARN ] [okhttp3.OkHttpClient                ] - A connection to was leaked. Did you forget to close a response body?

Things look to be OK ATM, if you are having issues , restarting the cloud binding might help.


Thanks Dan… Things looking good from here now.


Alexa up and running
push notifications working

Google home: Devices discovery still not discovering anything

do not mistake: i am grateful none the less :wink:

If Alexa is working, i’m not sure why Google is not, both use the same REST API. Can you confirm this is not a config issue?

Thanks :slight_smile:

Hi Dan…
Are you aware of whats changed with the update?

For some reason Google is responding with “…2 lamps” even though there is only 1 lamp/light tagged.
I´m pretty sure this wasnt the case yesterday, (before your update) So I wonder if this is a bug in Google Assistant somehow ??

Are you aware of whats changed with the update?

Google uses the REST api of your openHAB instance, myopenHAB just passes that through and does not touch nor store anything for it (other then auth keys). The release was mainly around Android push notifications and some minor Web UI fixes, nothing has changed in the proxy code that Google is using.

Thats weird…
When ever I ask Google to turn on a light, “she” respond with, “okay, turning on two lamps”. Even though there is only one lamp tagged. It seems to happen to all my tagged items. I have checked and doubble checked my items, and my Google Home settings. There is only one lamp…

I know for sure this wasn´t the case yesterday, cause I have been converting all my IHC items to use the latest IHC binding, and made serious tests each time I made changed to one of the tagged items.

Could be Google fooling around as well though… It´s not that stable right now. Just pretty annoying, and specially since there is no way to investigate this issue.