Myopenhab works, but very slow

I tried to use openhab beta4 via, it works, but only sometimes.
Internet connection is good.
At logs I can see that openhab2 connects to myopenhab server, at I can see online my openhab2.
Sometimes I see in logs:
2016-11-21 15:25:22.142 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 15351 failed: null (rather often)
2016-11-21 11:00:03.206 [ERROR] [o.myopenhab.internal.MyOpenHABClient] - Socket.IO error: io.socket.engineio.client.EngineIOException: websocket error (very seldom)
After that I removed and installed latest openhab2-online (deb /). There are no any errors at logs, shows OH2 online, everything is fine… but when i’m trying to access to my dashboard, web page looks freezed again… and it’s no difference, I tried to enter to dashboard via IOS app, safari or google chrome (win7). At beta4 Sometimes I had a chance to open dashboard (beta4), with the latest version dashboard was never opened.
After authentification OH2 at myopenhab, works very slow (I mean web pages opens too long time). If I disconnect OH2 from myopenhab, myopenhab opens fast.
At local network OH2 works good.

I use:

Orange pi one + armbian 5.20 with all latest updates

root@orangepione:/etc/openhab2/services# cat /etc/armbian-release
BOARD_NAME="Orange Pi One"

java -version
java version "1.8.0_111"
Java™ SE Runtime Environment (build 1.8.0_111-b14)
Java HotSpot™ Client VM (build 25.111-b14, mixed mode)

cat /etc/selinux/semanage.conf | grep -v "#"
module-store = direct

root@orangepione:/var/lib# iptables -L -v -n
Chain INPUT (policy ACCEPT 92 packets, 5964 bytes)
pkts bytes target prot opt in out source destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination

Chain OUTPUT (policy ACCEPT 98 packets, 9880 bytes)
pkts bytes target prot opt in out source destination

2016-11-21 21:27:36.822 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Connected to my.openHAB service (UUID = *****, base URL = http://localhost:8080)

Yes, same here, it’s slow at the moment.

If the problem persists you should think about if that is the right device for openHAB. openHAB did not very well perform on a Raspberry Pi One first model, I suspect the Orange Pi One will show the same behaviour.

At now don’t work at all…
About ARM architecture and OH&JAVA… Java and Debian is officially support ARM arhitecture, so I conclude that OH2 can work good at raspberry pi, orange pi and at others single-board computers.

Yes, on a Pi2 or 3 with much more RAM than an Orange Pi One.
But as soon as you have it working you could post your experiences.
And yes, my.openhab seems to be down at the moment. I have read somewhere that they are working on a bigger update, so let us be patient with this free service …

It works right now! I hope it will work good at the future too :slight_smile:

OH2 works good on Orange Pi One, I never see swap usage. Now I’m waiting Orange pi lite with wifi on board and orange pi zero with 256mb RAM and wifi on board also.
Offtopic, but I created a script for install OH2 on new armbian deploy, may be it helps someone (time by time I’m editing it):


timedatectl set-timezone Europe/Moscow
timedatectl set-ntp true
apt-get update
apt-get -y mc mtr git
apt-get -y upgrade
echo “deb xenial main” | tee /etc/apt/sources.list.d/webupd8team-java.list
echo “deb-src xenial main” | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp:// --recv-keys EEA14886
apt-get update
apt-get -y install oracle-java8-installer
sleep 1
apt -y install oracle-java8-set-default
cd /tmp
apt-key add mosquitto-repo.gpg.key
cd /etc/apt/sources.list.d/
apt-get update
apt-cache search mosquitto
apt-get -y install mosquitto
sleep 1
#echo ‘deb testing main’ | tee /etc/apt/sources.list.d/openhab2.list
#wget -qO - ‘’ | apt-key add -
echo ‘deb /’ | tee --append /etc/apt/sources.list.d/openhab2.list
wget -qO - ‘’ | apt-key add -
apt-get update
apt-get -y install openhab2-online
sleep 1
systemctl start openhab2.service
systemctl status openhab2.service
systemctl daemon-reload
systemctl enable openhab2.service
apt-get -y install firmware-ralink
apt-get -y install tcpdump

echo "Edit bashrc for ll command"
echo "execute cpufreq-set -r -u 480MHz and edit file: vim /etc/default/cpufrequtils"
echo "update wifi drivers: wget"
echo "for realtek two interfaces driver: or git clone"
echo “Temperature you can find at /sys/devices/virtual/thermal/thermal_zone0/temp”

Hm… Works, but slow again…

2016-11-21 23:22:07.108 [INFO ] [o.myopenhab.internal.MyOpenHABClient] - Connected to my.openHAB service (UUID = *****, base URL = http://localhost:8080)
2016-11-21 23:25:18.213 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 9401 failed: null
2016-11-21 23:26:33.488 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 10115 failed: null
2016-11-21 23:26:34.864 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 10132 failed: null
2016-11-21 23:27:48.879 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 10631 failed: null
2016-11-21 23:32:46.273 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 9660 failed: null
2016-11-21 23:33:38.983 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 12549 failed: null
2016-11-21 23:38:43.556 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 13086 failed: null

What does this error mean…?

Same here. I don’t have an idea, too.

I also do get these jetty request failed log entries.

I can reproduce them with my iOS app in remote mode. Every time I launch the settings in the app, I get two log entries:

2016-11-27 13:46:45.901 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 3513 failed: null
2016-11-27 13:46:45.910 [WARN ] [o.myopenhab.internal.MyOpenHABClient] - Jetty request 3513 failed: null

When the app is in local mode, I don’t get these messages.

After my last update of openhabian and openHAB to 2.1.0 Build #949 it startsvery slow on my Pi3 (>20 minutes until everything runs fine) - and I got a lot of these errors:

2017-06-19 07:38:13.456 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 3651610 failed: null
2017-06-19 07:40:11.227 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 3652407 failed: null
2017-06-19 07:41:19.868 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 3652841 failed: null
2017-06-19 07:44:40.667 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 3653875 failed: null
2017-06-19 07:45:10.833 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 3654035 failed: null

Known (and open) issue: