MyQ Binding 3.1.0 Stopped Working (Solved)

The MyQ Binding had been working perfectly for me until a week or so ago when it started giving an error:

2021-08-31 08:18:56.864 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'myq:account:5c8e5ac110' changed from OFFLINE (COMMUNICATION_ERROR): Invalid Response Code 400 : {
    "SecurityToken": "",
    "ReturnCode": "0",
    "ErrorMessage": "please contact customer care, supportID: 593427150195868209",
    "CorrelationId": ""
2021-08-31 08:18:56.874 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'myq:account:5c8e5ac110' changed from UNINITIALIZED to UNINITIALIZED (DISABLED)

I tried disabling it for a few days (thinking that perhaps the server was unhappy with too many requests), but that doesn’t help.

I am running OpenHAB 3.1.0 Release Build on a Pi 4B with OpenHABian. The MyQ Binding is 3.1.0.

Everything works was expected using the myQ app on my iPhone.

Any suggestions?


1 Like
1 Like

Same error here as well

Follow this post Chamberlain MyQ Binding - #714 by digitaldan of the other thread.

Thanks that fixed it.

1 Like

Not seeing the binding listed in Main UI for install
Where did you guys find it