MyQ Device Connection Issues

Just installed a Chamberlain MyQ-equipped garage door opener and I’m attempting to get it connected to OpenHAB. I’m on 3.2.0.M1.

I have the MyQ binding installed and have attempted to set up the things and items per the binding instruction: MyQ - Bindings | openHAB

I’ve verified the opener is on the correct WiFi network and have checked the username and password several times.


Bridge myq:account:home "MyQ Account" [ username="", password="XoXoXo, refreshInterval=60 ] {
    Thing garagedoor shop_door_south "Shop South Door" [ serialNumber="nnnnnLnnnL" ] 
    Thing lamp sgd_s_light "Shop South Door Light" [ serialNumber="nnnnnLnnnL" ]

The bridge seems to be connecting (the “MyQ Account” thing is showing as “ONLINE”), but the Thing states are both “UNKNOWN”. I’m not even moving onto the items as the things are not registering.

I suspect my issue is with my serial number. I pulled it right from the side of my opener; the sequence shown is “nnnn nLn nnL” where n=numerical digit and L=capital letter. The label shows spaces. I’ve tried it without and with spaces, substituted the zeros for ohs, etc.

Can any MyQ user offer some advice? Is the problem actually in my bridge?

@digitaldan, are you maintaining the MyQ binding, or do you at least have some insight?

Can you check your Inbox and see if the binding auto discovered the devices? You can then take a look and see what the serial number is and use it in your thing file.

Hi @digitaldan, that worked! I had to go into the inbox and scan the binding for things, but then they added. I had expected that since I’d created things within the bridge that I wouldn’t need to add any additional things (as with MQTT WiFi devices for example).
But it did interestingly pick up TWO things during the scan, and when I now search through my things for “MyQ” this is what I show:

I picked up the “MyQ Garage Door Opener” (which is erroring) and the “MyQ Shop Door South”, and I can successfully link items to the channels in that second thing.
The other two on the bottom are the things I created within the Bridge, per the binding instruction. Can I remove them?

Yes, you can delete them (from your thing file) , do the serial numbers in the manual things match exactly what the discovered serial numbers are ? I did test manually creating things, so i thought that should work, curious if thats the case or not.

Actually it’s strange now that I look at it, one auto discovered thing is in error, one is not, and your two manual things are now working, where before they were not, very strange. I would say try deleting the auto discovered things and see what happens (leave the manual ones). I’ll see if i can repeat that issue this weekend.