Need help to install OH2 on Windows

That is what I originally started with (see link above)

No luck!

I’m going to walk away from it for a while and come back to it later. The path for Java on my PC seems very long compared to what is being shown. [ C;\Program Files(x86)\Java\jre1.8.0_171\bin\javaw.exe ] I’ve tried shortened combinations of the path and I still get the same effect.

Maybe I should I uninstall Java and reload it?

I’ll reload versions 8 and have another go.

Success !!

I have now progressed installation, using the installation guide for Windows. I have progressed to the "Connecting to the openHab console part. I have installed Putty and completed the New Session Properties input. but I do not seem to be able to enter the password as stated “habopen”. I am just getting the following Capture

The cursor is a solid green box and does not respond to any keyboard input. Any suggestions? And what should happen next? The Installation Guide just stops after this?


solid green box or black box with a green frame (like in the screenshot)? :slight_smile:
the black box with green frame means that you haven’t clicked on the window to bring it in focus to be able to type into it.

By the way: If you started OH2 using start.bat you already have a working console to the OH2 system.
The ssh part of the installation instructions is useful when you start OH2 as a windows service.

Installation is finished when the OH2 service has started without any errors in the logs.

The next steps are here:

1 Like

You shouldn’t need Putty. Do you have a Karaf window open? It takes a long time to get started the first time - best thing is to look for lots of disc access. You should then get a screen like this

Once you get that try opening Internet Explorer at localhost:8080

I have now re installed openHAB and will use Chrome. But I am getting the following message when i click on “start”


I have visited the page suggested but do not know what to look for. There is a vast amount of stuff on there and I dont want to choose the wrong fix. Can ayone help with this?


this should be fine (since it’s only a warning)
OH2 should be up and running now
can you access the web interface?

If you want to get rid of this warning, install Oracle JDK 8 (Java SE Development Kit 8u172)

You need to install

I installed the kit and now get this message

any ideas?

make sure that you JAVA_HOME system environment variable is set to the JDK root dir

Its got to be one of the most frustrating pieces of software I have ever installed! I have spent too much time on it so I am going to give up again.

Can we try to get all information we need:

  1. Which version of java have you installed? (JDK, JRE)
  2. exists a directory name C:\Program Files\Java\jdk1.8.0_1xx or in the x86 folder?
  3. is JAVA_HOME=C:\Program Files\Java\jdk1.8.0_1xx?

Please keep in mind JDK is important, not JRE! JRE can be uninstalled, not needed.

Can you just check this?

I have to agree with yo u on one thimg. Anything java is a pain in the arss!

I like openhab and switched to openhabian to avoid the pain. The best thing I ever did as I have a hhate anything java! It’s just that many java based apps always seems more difficult then they need to be. You would think someone could have a one click install these days.