Need help with Astrobinding Offsets


I am scratching my head over the question, how to use the offset functionality in the Astrobinding 2.0

As I understand the documentation, I would need to add a thing in my astro.things to modify it. So I added
astro:sun:home [ geolocation=“48.5216364, 9.0576448”, altitude=100, interval=60 ] {
Type rangeEvent : astroDawn#event [
To move the event trigger to 20 min more early. But as this does not work for me, I obviously understood something wrong? Maybe somebody can point me in the right direction?

The binding itself works fine, it triggers all sorts of thing at the defined point in time. But as I would like to move my shutters 15 min before civilDawn, I would need to configure an offset for that event. So the astroDawn is just an example.


astro:sun:home [ geolocation="xx.xxxxxx,xx.xxxxxx", altitude=100, interval=60 ] {
        Type rangeEvent : civilDawn#event [
astro:moon:home [ geolocation="xx.xxxxxx,xx.xxxxxx", interval=60 ]

(not tested)

Excuse me sihui, why are you pointing me to the documentation I just mentioned to struggle with? Especially when you add a “not testet” to your post?
This hidden “rtfm” is neither helpful nor nice.


Edit: Interesting enough, that you gave some useful advice on this general topic in annother post: Simply turn on at sunrise, turn off at sunset in openhab2

So maybe you know something helpful about the text-based config as well? :slight_smile:


Is your OH2 up to date? Offset was integrated… hhhmm… don’t remember… January?

Where can I check the version please? I installed everything from scratch today, using the january package of openhabian (as the latest version showed some strange odds on my system). Then I did a apt-get update && apt-get upgrade. After boot, i can see the Welcome screen stating OH as far as I remember. Is this the most recent one?

Offset does work within the PaperUI, I discovered. What I am missing is the latest/earliest functionality as well as the text based version of offset does not work (or, most probably, I do not understand the documentation correct)

Especially for you I tried setting up a text based config, this is working for me:


astro:sun:homeplus90 [ geolocation="yy.aaaaaa,y.bbbbbb", interval=60 ] {
    Type rangeEvent : civilDawn#event [


rule "example trigger rule"
       Channel 'astro:sun:homeplus90:civilDawn#event' triggered END 
       logInfo("FILE","civilDawn event +90 offset triggered successfully on END")


2017-03-05 08:39:00.173 [INFO ] [.eclipse.smarthome.model.script.FILE] - civilDawn event +90 offset triggered successfully on END

As you can see the answer was in the mentioned doc.

I had no usecase for an offset so I added a “not tested” because I did never test that, I even did not have any setup for an offset.

If you don’t like my answers go to your account settings, “Preferences”, scroll down to “Users” “muted” and put my username in that field. Don’t forget to hit the “Save” button.

Hi sihui,

now this one was a really helpful answer, thanks a lot and especially for the efforts you took especially for me :slight_smile:

From your test I would say, you where doing exactly the same as I did, as I stated in my first post. So we both followed the documentation, which did work for you but, for whatever reason, not for me. That was the reason I perceived your simple, uncommented link to the doc as “kind of rude”, as I read it already and did what I understood from it (which, as stated, did and does not work for me). So no, I do not dislike your comments at all :slight_smile: (surely you have way more knowledge here as I do), I just disliked that specific comment that seemed to imply I had been too lazy or too dumb to read documentation when my example just showed the opposite.

Now with that out of the way :wink: let’s move back to the topic:
What version are you on, if I may ask? I would suspect we run different builds, which may cause the different behaviour? I am on 2.0.0-1 (Release build). I read somewhere, that the astrobinding received some new functions in february, or so. So maybe the relase version is my problem here.

Have a great sunday

I think SiHui is using the Nightly Build version, that way you can get regularily upgrades. Perhaps you are using the Stable Build version. I did start with th SB as well, and when i runned into problems with mqtt, i switched to NB.
In an reaction from Kai, he mentionned that he/the team is still working on a modus to get upgrades for the stable release.

I learned most experts on the forum are using nightly builds, so if you are in the need of more help, perhaps it is a good strategy to switch also to nb :wink: Might overcome confusion…

That’s quite interesting to know, thanks a lot.

Hopefully they are going to figure out that problem quite soon, so I don’t have to bring too much risk in here…as OH2 is inteded to really operate my House on a daily basis, I am a big fan of stable versions here :yum: How stable are these NB?

All good in the hood. :grinning:

The nightly builds as @deltabert already stated.[quote=“Zaphood1967, post:10, topic:24326”]
How stable are these NB?

Pretty stable but you can never be sure if some code changes break your system (it never did at mine).

You too!