Need some help, what am I doing wrong?

You must have multiple java versions installed
What is the output of the command sudo update-alternatives --config java That should list all installed java versions.

For reference, here is my output.

There is only one alternative in link group java (providing /usr/bin/java): /opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/bin/java
Nothing to configure.

hey Bruce that was spot on. Here is the output:

There are 2 choices for the alternative java (providing /usr/bin/java).

Selection Path Priority Status

  • 0 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 auto mode
    1 /usr/lib/jvm/java-11-openjdk-amd64/bin/java 1111 manual mode
    2 /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java 1081 manual mode

Press to keep the current choice[*], or type selection number:

I think you should run that command again and choose option 2. Running it again to check should move the selected indicator to Java 8, I hope.

it did work as you expected. Now to I just run the
sudo openhabian-config command, or do I need to fully start over.

I have never really done this.
We may get lucky. Try sudo systemctl restart openhab2 It may just start up now.

so I did that and the result was same output as before. then I ran the Openhab-config command and here is my results:
$ java_install_or_update
openjdk version “1.8.0_222”
OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

$ systemctl stop openhab2.service
Failed to stop openhab2.service: Unit openhab2.service not loaded.
/opt/openhabian/functions/java-jre.bash: line 181: curl: command not found
openjdk version “1.8.0_222”
OpenJDK Runtime Environment (build 1.8.0_222-8u222-b10-1ubuntu1~18.04.1-b10)
OpenJDK 64-Bit Server VM (build 25.222-b10, mixed mode)

$ systemctl start openhab2.service
Failed to start openhab2.service: Unit openhab2.service not found.
FAILED
homeautomation@Homeautomation:~$

sudo apt-get install curl
Apparently that program is not installed.

so that appear to me successful, but here was my output:

08802025/108802025] -> “/tmp/openhabian.lIOsU/zulu8.tar.gz” [1]

$ update-alternatives --remove-all java

$ update-alternatives --remove-all javac

$ update-alternatives --install /usr/bin/java java /opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/bin/java 1083000
update-alternatives: using /opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/bin/java to provide /usr/bin/java (java) in auto mode

$ update-alternatives --install /usr/bin/javac javac /opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/bin/javac 1083000
update-alternatives: using /opt/jdk/zulu8.42.0.21-ca-jdk8.0.232-linux_i686/bin/javac to provide /usr/bin/javac (javac) in auto mode

$ wget -nv -O /tmp/openhabian.aTqAX/crypto.zip http://cdn.azul.com/zcek/bin/ZuluJCEPolicies.zip
2019-11-21 16:44:21 URL:http://cdn.azul.com/zcek/bin/ZuluJCEPolicies.zip [12181/12181] -> “/tmp/openhabian.aTqAX/crypto.zip” [1]

$ unzip /tmp/openhabian.aTqAX/crypto.zip -d /tmp/openhabian.aTqAX
Archive: /tmp/openhabian.aTqAX/crypto.zip
creating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/
inflating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/LICENSE
inflating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/README.txt
inflating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/DISCLAIMER
inflating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/local_policy.jar
inflating: /tmp/openhabian.aTqAX/ZuluJCEPolicies/US_export_policy.jar
OK

$ systemctl start openhab2.service
Failed to start openhab2.service: Unit openhab2.service not found.
FAILED
Question should I wipe the install and start over ?

That might not be a bad idea. Here is what I usually select in openhabian-config.
60 Fresh / Manual Setup Under there I select the following bu using the space bar.

62 Packages
63 Zulu OpenJDK 32-bit
64 [Select your chosen build]
65 System Tweaks
66 Samba [if desired]
67 Log Viewer

I then select Execute.

So is your recommendation to not do thru
01
02
10
20
30
40
50 and skip down to 60 and start there? Is there any potential consequences with doing it this way? 20,30 and 40 seem important unless i am able to come back and do them later.

My choices were based ion this quote from the documentation.

You’ll see the openHABian configuration menu and can now select all desired actions. The “Manual/Fresh Setup” submenu entry is the right place for you. Execute all entries one after the other to get the full openHABian experience:

01 just updates openhabian itself. It usually checks and suggests if it needs updating.
02 is the same as running sudo apt-get update followed by sudo apt-get upgrade. I usually run those & reboot before running the config tool.
10 is probably the same as 65
20 has a few more options that can be selected later if desired. I do not use any of them.
30 replicates some of the raspi-config tool that openHABian removes.
40 may be useful for Reverse Proxy or to delay loading. I manually installed my reverse proxy. I did not realize that menu selection was there.
50 I probably should setup backup but I think it could be some after successful installation.

20, 30, 40 should be able to be run later.

Great news guys. I finally got it up and running . I know , i know, it should not have been that hard, but i have to say that this has been a learning experience. Do I want t to have to put this much work into something that will run my whole house? maybe we will see. The biggest issue I have is my lack of linux knowledge which creates a reliance of folks like you Bruce for the bare basic, I am now the single point of failure. Anyways it got it running.

Question:
On the VM where I have Openhabian running I am able to access the gui. On the windows box the host the VM I am not able to access localhost :8080. How can i make sure that I am able to access the interface from any device in my house while in the process of setting up the system?

What type of vm? I. Virtuabox you set the nic to bridged so the vm gets its own IP address on the network. You access it by that address, not localhost.

hey guys not sure if this need to move, but I am placing it here for now.

I install openhab cloud. Created the user name and password
then inserted the UUID
then inserted openhab secret

I then rebooted openHab and refreshed openHab Cloud page , but the end result is still saying the the page is offline. I have done the whole setup twice and I am still coming up will openHab cloud being offline. Anyone have any idea why this could be happening?

maybe it is offline or… you have a connection issue maybe??? make sure you really are connected. Isn’t there a way you can check in a browser if I recall correctly

No the server is completely online. I am able able to access Paper UI on multiple system. I have deleted the OpenHabcloud install in Paper UI and reinstalled it more times than I can remember. I am now not able to register the UUID to a different email as it is reports it as being used by a different account.
I have attempted to reset my password more than 6 times. I have yet to receive a reset email. (yes I am using the correct email. I still have the activation email) I have yet to receive 1 reset email. Where do i turn to now. how do I get this fixed?