NEEO Remote Binding/Transport


(DiLucca) #342

@morph166955
The slider is working better but the issue you are experiencing is still present in my remote as well. In order to get the slider to update I have to go to the main menu and back to the device.


(DiLucca) #343

It looks like the Timeout on NEEO’s Add Device is 4 seconds. That’s why I’m unable to add devices. Do you have any tips on how to improve the ‘db/search?q=…’ speed? My setup is fairly simple but it takes around 6 seconds to reply back. (RP3)


(B R) #344

Unfortunately, I’m not having the same luck with the slider. Text boxes update almost immediately. Would you mind sharing your item and neeo transport config so I can compare?


(DiLucca) #345

@morph166955 Spoke too soon, I did some tests last night and the remote behaviour was pretty erratic…

Looks like the whole UI is still busted when it comes to the interaction with Sliders and Switches. ie turning one switch to On causes all switches to switch on…

To get the sliders to update I have to ‘move’ the slider on the remote first… this seems to awake it.

I already bailed on the remote for this type of interactions until the guys @ NEEO recode the UI framework on the remote.


(Tim Roberts) #346

@morph166955
Believe it or not - the next NEEO firmware has a feature similar to this (device versioning). Looks to be a little limited (only for adding new capabilities to a device - not for dropping or updating existing capabilities). As soon as I have more details - I’ll be making a new version of the transport to allow the versioning


(Tim Roberts) #347

@DiLucca

  1. Because we went through an official review - 2.3 will not be supported (as part of the review, I had to use some newer items only available for 2.4).
  2. Yes - you are running into the timeout issue as you have documented. The only advice I can give is to make your search as narrow as possible (“openhab thingname”) - which should speed up the search.

(Tim Roberts) #348

@morph166955 and @DiLucca

Rumor has it the slider (and switch) issue is fixed in the next firmware


(B R) #349

@tmrobert8 Thanks on all of it!


(DiLucca) #350

@tmrobert8 Thanks for all the updates!

BTW I’ve tried with narrow searches but the response always takes 6 seconds, I assume the search always loops through all my Things (+100) regardless if they are NEEO Type enabled (15). I assumed this because it’s the same amount of time that it takes for the Transport to ‘Refresh Things’.


(Tim Roberts) #351

@DiLucca

Should only pick up on the things you have mapped UNLESS you have the the Integration (not transport anymore) options set to include everything.

Open up the PaperUi->Configuration->Services->Neeo Integration->Configure. Make sure both “Expose” switches are OFF and save it. Should work immediately - but you may want to restart openhab (and reverify the settings are saved) before you give it a try again.

Tim


(DiLucca) #352

@tmrobert8
Expose All is set to Off, but is it possible that the transport loops/search through all the things (on each search) regardless, before picking up what to expose?


(Derrick Senela) #353

Could someone please walk me through the process of binding to hard keys on the remote? I am in the process of trying to finish setting up the Onkyo OH driver to work with NEEO (I know there is an IR driver, but I really must use IP control). I am interested in having the volume and mute functions specifically mapped to the hard buttons on the remote. I have tried to follow the little info available but cannot get the remote hard buttons to respond to these functions. The onscreen icons for these works fine, so I know it is just an assignment issue. Do I need to create separate buttons for both Volume UP and Volume DOWN and bind them to the hard keys?

Below is how I have it set currently:


(Tim Roberts) #354

@morph166955

I just submitted the PR that will support the forthcoming 52.x firmware release that will allow you to ADD capabilities without having to drop/readd the device (only ADD is supported by NEEO - they are afraid UPDATE/REMOVE of capabilities would break recipes). Once the PR is merged - there is a new driverVersion property under advanced properties. When NEEO detects the driver version is higher than the current one - it will merge any new capabilities in without any user interaction. Please note that you should never have to modify this property as it’s incremented automatically when you save changes.

This version also adds support for UI actions when a list item is clicked on (so you can say ‘close’ the list when you press it).


(Tim Roberts) #355

@DiLucca
No - the only way it loops through everything is if you have expose all on.


(Tim Roberts) #356

@dsenela

Based on the screen print - you need to change the “(Exclude)” to “Button”. Right now you are excluding all the various channels. You need to map them to buttons - then you map to the hard keys (VOLUME UP, etc).

Some of it also depends on the type of device you have (ACCESSORY for example doesn’t support hard keys).

Note: You can simplify the source input by making a LIST type (where you can map 40, 41, 42 to individual choices in the list).


(Derrick Senela) #357

Thanks for your response, I really appreciate it. I did manage to get the hard buttons mapped and they are working OK now. For some strange reason even after selecting ‘Button’ the display still reverts back to ‘(Exclude)’ after saving, but the buttons work fine all the same. My selected device is ‘AVReciever’. Thanks for the handy tip on using a LIST type to manage my sources, very helpful!


(Tim Roberts) #358

The change to enable support for 52.x (still in beta) has been merged. This adds:

  1. Driver Versioning - this allows you to add items to devices without having to drop/readd the device on NEEO. Only works when adding items - not updating or deleting. If NEEO every allows updating/deleting - should be no changes on our end
  2. UI Actions for list items - this allows you to specify what happens when you click on a list item (such as closing the list).

BIG ISSUE
The latest 2.4 snapshot includes an update for an eclipse component called Jetty. This update includes a SERIOUS bug that NEEO triggers (which will prevent the integration side from working properly). Please follow https://bugs.eclipse.org/bugs/show_bug.cgi?id=540970 if you are interested…


(Andreas Loibingdorfer) #359

Hi,
Starting to use your Transport with Neeo.
Having a Loxone Thing (Light Switch)
With OpenHAB I am able to switch the Light on and off
Now on the Neeo Transport I have configured a new virtual Thing with Neeo Type Power and a 2nd one with Neeo Type Switch (POWERONOFF).
I am able to Power on or Power off the Light on my Neeo App with the Recipe Testings.
But my Neeo does not know the Power State I think because when I Power on the LIght it does not give me a Power Off Button.

Best Regards


(Tim Roberts) #360

Lights are a bit finicky on NEEO because they have a special UI and are harder to setup. I’m assuming you created the virtual thing with a NEEO type of ‘Light’? Could you show me your definition (take a screen print of it and post it to the forum)? That would help (and I could try to replicate it with my hue lights)


(Andreas Loibingdorfer) #361

Hi,

Thank you.
Tried it this way: