Neo coolcam z-wave devices

zwave
Tags: #<Tag:0x00007fe0603a1f40>

(Chris Jackson) #207

In this log, did you actually wake up the device so that it can initialise? If so, there is no sign of this. Currently the binding is waiting for the device to send a wakeup notification, and there is no communication with the device yet.


(J Wee) #208

Should i “wake” the battery sensor, or the Aeotec Z wave stick? Or both?
Is the Z wave stick supose to be switching between blue, orange , red all the time while its in the usb port of the ubuntu VM?

From what I read just pressing the button on the sensor wakes it, when I see a little red light


(Chris Jackson) #209

You can only wake battery devices. Other devices do not sleep.

Yes - I think that’s normal.


(J Wee) #210

ok. tried waking up the sensor. This is my latest log
https://drive.google.com/file/d/1z-eOAxK_5N56QhVmuUE7sK4-ImBkgA46/view?usp=sharing


(SiHui) #211

Only your controller and node 3 are showing data, still nothing from your not working node.

If that is the case, everything is fine :sunglasses:

I have only one Neo device (flood sensor), despite the manual saying click the button once to wake it up, I need to triple click the button to wake it up …


(J Wee) #212

I think node 3 is my “non-working” node.
I dont think its fine because its still listed as unknown device (although it also says online).
Why isnit it listed like this?
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/400

Which is exactly the device I have


(Ben) #213

@epicurean: Just open paper ui and watch your thing. There it shows online I guess. So take the neo sensor and tripple click the button inside for several times. After a while you will see the online text will change to a ‘—’. Tripple click the button again and leave it. After that procedure it will be recognized as the door sensor.


(J Wee) #214

Alleluia!. It finally worked! Thanks so much to everyone who were so patient with me.
Now is there anyway to save these settings?
Will powering off and on, and everything I have done will be lost ?


(Ben) #215

No nothing to do. Everything will be saved :grinning:
Next time you can just wait till the device will wake up for its own. Then it is shown up in habmin or the paper ui as an already recognized device.
I included around 27 neo sensors in my system and you will always have to play with the button inside the sensor to wake them up.


(Mac McIlvaine) #216

I have a HAOZEE version of NEO. It binds as a NAS-WR01ZE.

I’m running the previous snapshot from a few days back of openHABian.

The device included just fine.

But, if I send it an on command it comes on and immediately changes from online to offline in the log.

If I then do a factory reset (hold the button on the device for 10 seconds) it goes back to online…until I send another on command.

I also note, in HABmin> Tools>Z-wave Network Viewer, that it never shows as linked to another device. (I see the same for a Aeotec Micro switch as well…but it works just fine)

Any thoughts on how to fix this?

Regards,
Mac


(Chris Jackson) #217

The first question is what is really happening. If you really do a “factory reset” on a device, it should remove itself from the network - not go online. Problems with devices going offline are normally caused by timeouts, which generally occur when devices are close to being out of range.

To debug what is happening, you need to get the debug logs. You can use the log viewer on my website to view these if you like.


(Mac McIlvaine) #218

Cool…so do I copy one/both of these to a PC with browser access?

/var/log/openhab2/openhab.log
/var/log/openhab2/events.log


(Chris Jackson) #219

Just the openhab.log is required - depending on how you have your system configured, you should be able to access it directly using a samba share…


(Mac McIlvaine) #220

No samba…no windows in this house, all linux.

Are you saying it needs a real time view of the file?

I already have an NFS share from one linux box on the openhabian pi.
I currently only NFS client setup on the openhabian pi. (Or maybe NFS server is set up and I just haven’t tried it…)


(Chris Jackson) #221

Ok, but I believe you can still share network drives on linux? :wink:

No - simply that you don’t need to copy it somewhere else to open it.


(Mac McIlvaine) #222

As I noted later in that post. :sunglasses:


(Scott Rushworth) #223

Samba is not just for Windows, and openHABian includes a couple pre-configured Samba shares.


(Mac McIlvaine) #224

True that, it’s not only for windows.
And there may be samba shares on openhabian.

But, at this point I have nothing using Samba, thus I’d need to actually set it up on a some machine in my network…for moment call me lazy. :blush:


(Scott Rushworth) #225

Lucky for you, there’s no setup required… just install a Samba client, if you don’t already have one :wink:. VS Code will use these shares too.


(Mac McIlvaine) #226

That’s the point I have never needed more than NFS. I have a dozen PC’s running some form of Linux. I rarely use WINE…unless it comes from a bottle. :sunglasses: I have no Samba clients.

And, VS Code?