Neo coolcam z-wave devices

zwave
Tags: #<Tag:0x00007fe0549724f8>

(Fro) #81

Device is in the database for sure. I did node myself and Chris added device to the database. I’m still in OH1.x
Look in to Habmin.


(Leo Verkaik) #82

Sorry Fro,

But I think the switches are not yet in the live database…
As far as I can see your entry of it is waiting for review.
In my Habmin I see 4 Shenzhen devices, but not the switches.
Chris wrote we had to export them and make a PR on GitHUB. Would you know how to do that?


(Fro) #83

Yes. Both waiting for review becouse in 2-channel switch I changed the desctription… but only desctription.
Look at the posts above. New device is only 1-channel switch.
2-channel switch we added to the database two months ago and I used zwave binding from june.


(Leo Verkaik) #84

I’ve installed the 1.11.0-snapshot zwave binding, and I see only 4 Shenzhen devices, and not the 2-channel switch, what could be wrong then?


(Fro) #85

You see somethink like this?

…and what kind of controller are You using? Maybe something went wrong with inclusion to controler.


(Leo Verkaik) #86

Yep, That’s what I have also.
I think the database is in the tab Product Explorer. If I open Shenzhen, I get 4 products, not yet including the switch you defined Fro.


(Fro) #87

It doesn’t matter. It is Important that You have the same what I showed You.
what kind of controller are You using? Maybe something went wrong with inclusion to controler.
My switches work with OH1.83 without any problems.


(Leo Verkaik) #88

I’m using the Aeon Labs Gen 5 USB stick, Openhab 1.8.3 and downloaded the zwave binding from your link (1.11.0 snapshot dated September 2017)
First Included the switch with the 1.10 zwave binding, I’ve excluded it and included it with the 1.11 version.
Still no reporting of manual switching on the Neo switch. OpenHAB commands are executed by the switch though.

I think it’s the setting in the association groups that’s causing it, but one can only change the settings if the switch is defined in the database, that’s what Chris wrote.

But I don’t understand why your switches are working flawlessly…?
Have you used another controller to change the settings before linking it to OpenHAB ?


(Fro) #89

I’m using the Aeon Gen5 stick too, OH 1.8.3 and zwave binding 1.11.0 - everything the same like You.
I don’t think it’s absent of neo switches in the database - I have the same.
I always include zwave items to controler by my laptop and aeon software or just by stick. Not by raspperyPi and OH habmin software.


(Leo Verkaik) #90

Aha, that’s your luck! :slight_smile:
I used habmin.
Now I feel confident it will work after I can set the association groups right.
I hope Chris will be able to help me to get the switch definitions into the database and into the zwave binding snapshot.


(Fro) #91

Try include just by stick…


(Leo Verkaik) #92

Lol, that’s it Fro !
Include with the stick, not by Habmin, OK now !

Thanks


(Fro) #93

:slight_smile:


(Leo Verkaik) #94

I did an upgrade to OH2 in both of my OpenHAB installations, it’s a lot of work but it’s worthwhile. OH2 is much more stable and zwave is better supported. My NEO devices and ZwaveMe (Popp) devices are now fully supported.


(Vasco) #95

hi guys

Update: I struggled for extended time and finally gave up. I decided to chuck this device in the bin and would not recommend buying it. It appears their Z-wave chip is not fully compliant.

As per below I had following issues:

  • pairing: it took several try&error before this device finished the interview properly. It also created a couple of ghost nodes which I still try to get rid of.
  • once paired it did indicate motion via the red LED but did not report anything towards my OH2
  • instead of the motion trigger I just received the error “2017-09-29 20:49:29.744 [ERROR] [ve.internal.protocol.ZWaveController] - Exception during ZWave thread: Input 2. {}”

Above flooded my log file and I couldn’t figure out a way to get rid of this. Also I tried to get rid of the red flash once motion is detected as I prefer stealth mode (and powersaving). For some reason the device has this as parameter but never accepted my change.

Even yet it’s half the price of the original version for me it’s not worth the trouble. I do hope they get their chip under control and one day might be an alternative. Until this time I’ll stick with the original.
Also I shall mention: this knock off lags the temperature sensor and can only flash in red. The original one do offer a wider application and customization.


I also struggle to get my Neo Coolcam PIR sensor running in OH2
I came to the point that it’s initialized and all items(file) are linked.
However when the device is triggered no event is shoting but instead I get below error in the openhab.log

2017-09-29 20:49:29.744 [ERROR] [ve.internal.protocol.ZWaveController] - Exception during ZWave thread: Input 2. {}
java.lang.IllegalStateException: Could not update state, because callback is missing
at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.updateState(BaseThingHandler.java:267)[105:org.eclipse.smarthome.core.thing:0.9.0.b5]
at org.openhab.binding.zwave.handler.ZWaveThingHandler.ZWaveIncomingEvent(ZWaveThingHandler.java:1104)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.ZWaveController.notifyEventListeners(ZWaveController.java:567)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveBinarySensorCommandClass.handleApplicationCommandRequest(ZWaveBinarySensorCommandClass.java:121)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.serialmessage.ApplicationCommandMessageClass.handleRequest(ApplicationCommandMessageClass.java:119)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingRequestMessage(ZWaveController.java:248)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.ZWaveController.handleIncomingMessage(ZWaveController.java:214)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.ZWaveController.access$7(ZWaveController.java:208)[183:org.openhab.binding.zwave:2.1.0]
at org.openhab.binding.zwave.internal.protocol.ZWaveController$ZWaveInputThread.run(ZWaveController.java:1324)[183:org.openhab.binding.zwave:2.1.0]

I tried the waiting and needed to include it and wake up many times to get to this point. However more including and waking up doesn’t seem to help anymore.

my items are as follow:

Number  Coolcam_PIR_lum                 "Luminance: [%.0f Lux]"                 { channel="zwave:device:controler:node24:sensor_luminance" }
Contact Coolcam_PIR_alarm               "motion sensor alarm [%s]"              { channel="zwave:device:controler:node24:alarm_burglar" }
Contact Coolcam_PIR_motion              "motion [%s]"                           { channel="zwave:device:controler:node24:sensor_binary" }
Number  Coolcam_PIR_battery             "PIR sensor battery [%d %%]"            { channel="zwave:device:controler:node24:battery-level" }

(Smee) #96

I had similar problem. Solved it by changing the items from Contact to Switch.


(jwveldhuis) #97

Thanks, very strange… By changing the item type of the door sensor to ‘Switch’ it indeed works, for ‘Contact’ nothing happens.

Any explanation for this?


(Chris Jackson) #98

You have to use the appropriate type for the channel - you can’t just use any item type you choose (which I think many people do since that was possible in OH1).

What device is this for?


(jwveldhuis) #99

It’s a door/window sensor. So expected the Contact type, not a Switch.


(Chris Jackson) #100

Sure, but what is the device? ie please provide the link to the database (preferably), or the device name, model or something.

We can look at updating the database, but please tell me what the device is :wink: .