Netatmo Binding: How to fix "Invalid Grant"?

Hi there!

A few days ago, my NetAtmo binding stopped working. In the logs I find

Thing 'netatmo:account:abcdefgh' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): Unexpected error deserializing '{"error":"invalid_grant"}'

I checked in the forum here but I could not find this recent issue (only old issues with different causes). I logged in to my dev account dev.netatmo.com and tried to access the Netatmo App I created. I got a 404, also for creating new Apps, I got 404s. After logging out and in again, I had access to my exisiting app and also could create new apps again.

I think, if I knew a way of how to log out and in with openHAB, this would fix my issue. Can you support me on how to do this?

Best regards,
ceedee

I’ve got a similar issue.
Authentication error, but the devices seem to work and appear online in openHAB.

2024-01-31 11:16:49.608 [ERROR] [oauth2client.internal.OAuthConnector] - grant type refresh_token to URL https://api.netatmo.com/oauth2/token failed with error code invalid_grant, description

2024-01-31 11:16:49.617 [WARN ] [service.internal.HttpServiceDisabled] - Http service has already been stopped

2024-01-31 11:16:49.620 [WARN ] [service.internal.HttpServiceDisabled] - Http service has already been stopped

2024-01-31 11:16:49.622 [INFO ] [etatmo.internal.servlet.GrantServlet] - Registered Netatmo servlet at ‘/netatmo/connect/xxxxxxxxxxxxx’

2024-01-31 11:16:49.623 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler ApiBridgeHandler tried updating the thing status although the handler was already disposed.

2024-01-31 11:16:49.627 [WARN ] [handler.capability.WeatherCapability] - Error retrieving weather data ‘70:ee:50:7a:71:80’ : Not authenticated

When I go to dev.netatmo.com I got an error 500

500 | COMMON.SERVER ERROR