Netatmo binding on Openhab 1.8.3. no lonnger working

I had my Netatmo binding working for approx. 2 years without any issues. Since mid-August it stopped working, the Netatmo values do not refresh anymore in Openhab. I have the following error:

2019-09-15 19:53:48.307 [INFO ] [.o.b.n.internal.NetatmoBinding] - The following Netatmo measurements are not yet configured:
70:ee:50:29:6f:4a#Temperature (Indoor)
70:ee:50:29:6f:4a#Noise (Indoor)
70:ee:50:29:6f:4a#Humidity (Indoor)
70:ee:50:29:6f:4a#Pressure (Indoor)

2019-09-15 19:53:48.689 [ERROR] [.service.AbstractActiveService] - Error while executing background thread Netatmo Refresh Service
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
at java.util.ArrayList.rangeCheck(Unknown Source) ~[na:1.8.0_201]
at java.util.ArrayList.get(Unknown Source) ~[na:1.8.0_201]
at org.openhab.binding.netatmo.internal.NetatmoBinding.processMeasurementResponse(NetatmoBinding.java:579) ~[na:na]
at org.openhab.binding.netatmo.internal.NetatmoBinding.processMeasurements(NetatmoBinding.java:361) ~[na:na]
at org.openhab.binding.netatmo.internal.NetatmoBinding.execute(NetatmoBinding.java:124) ~[na:na]
at org.openhab.core.binding.AbstractActiveBinding$BindingActiveService.execute(AbstractActiveBinding.java:156) ~[na:na]
at org.openhab.core.service.AbstractActiveService$RefreshThread.run(AbstractActiveService.java:173) ~[na:na]
2019-09-15 19:53:49.029 [INFO ] [.p.rrd4j.internal.RRD4jService] - Removing invalid defintion component = null heartbeat = 0 min/max = 0.0/0.0 step = 0 0 archives(s) = [] 0 items(s) = []

What could be wrong?

If you are really running OpenHAB 1.8.3 you cannot expect any recent experience from the people here.
You should have moved to OpenHAB 2.X a LONG time ago. If you expect any assistance, research & upgrade to something more recent. The latest Stable version is 2.4 but thet is over 6 months old. The latest testing, which incorporates many changes due to future plans, is 2.5M3.

People here currently are likely evenly split between 2.4. and one of the 2,5 Milestone builds.

I’m running the Netatmo 1.X binding on 2.4 with no issues. The Netatmo 2.X binding is still missing functionality from the 1.X binding.

1 Like

Many people are running 1.X bindings on OH 2 but somebody running OH1 should not expect any support, except to migrate to OH2 first, IMO.

Have you filed GitHub issues? Wherever possible OH1 binding will disappear in OH3.to permit updating to a more recent Java version.

Even if OH2 is out for years, there are good reasons to stay with OH1. :smile:

Personally I have got a running OH1 with the Netatmo binding org.openhab.binding.netatmo-1.8.3.jar still without any problems.
@ sam_calmes7, are you sure that your issue is originated in the binding?

1 Like

Something must have changed but I do not know what. It used to work well. I tried reconfiguring the binding information and have 2 questions:

  • when I authorize the Netatmo application I get first a Netatmo screen that looks normal then I click authorize and I get the following error in my browser:

HTTP ERROR 404

Problem accessing /test/. Reason:

ProxyServlet: /test/

Powered by Jetty://

Is this normal?

  • I am not sure anymore about the API key in refresh token in the config file; I get a double API key like:

[quote=“sam_calmes7, post:7, topic:81986”]
Something must have changed but I do not know what. It used to work well. I tried reconfiguring the binding information and have 2 questions:

  • when I authorize the Netatmo application I get first a Netatmo screen that looks normal then I click authorize and I get the following error in my browser:

HTTP ERROR 404

Problem accessing /test/. Reason:

ProxyServlet: /test/

Powered by Jetty://

Is this normal?

  • I am not sure anymore about the API key in refresh token in the config file; I get a double API key like:

5957d032e8ede1085e8b66d4|b207658c0cdf2b4ff4d633907419dc07

Should I put the whole thing or just the left side before the ‘¦’ or the right side into the configuration file?