Netatmo Binding receives empty data

Dear community,

I am trying to capture sensor data from Netatmo Healthy Home Coach.using Netatmo binding binding-netatmo - 2.2.0. I configured Netatmo Binding and Netatmo Bridge API. Both are shown with the status online. The problem is the binding does not catch any data (see screenshot below).


Netatmo API per manual call provides data correctly:


_id: "70:ee:50:26:30:ea"
cipher_id: "enc:16:83FjofKyhEsbPp/LBwgtv4UpqQxP2Wk4gQo/5YnBaSVyCcg0ur52rVgcC7XmneMI"
last_status_store: 1513725919
►place:[object Object]
type: "NHC"
►dashboard_data:[object Object]
co2_calibrating: false
date_setup: 1509915260
last_setup: 1509915260
firmware: 36
last_upgrade: 1509915261
wifi_status: 33
name: "LivingRoom"
►user:[object Object]
status: "ok"
time_exec: 0.025153875350952
time_server: 1513725922

How can I troubleshoot this situation? Is there any traces of Netatmo module which I can check?

Thank you and regards,

It would be good if you could check the logs for errors and post the relevant stuff. It would enable more people to help you


Hi Anton,

Did you activate the readHealthyHomeCoach Switch in the API Thing configuration?


Yes, Martin, API Netatmo brigde is configured to read Health Home Coach data:



Thank you for the suggestion, Martin! Unfortunately, /var/log/openhab2/openhab.log has nothing sind 19.Dec, last record was:

017-12-19 23:35:34.643 [INFO ] [netatmo.handler.NetatmoBridgeHandler] - Initializing API Connection and scheduling token refresh every 5400s

/var/log/openhab2/events.log also does not have any fresh entries:

2017-12-23 12:53:29.446 [vent.ItemStateChangedEvent] - Online changed from ON to OFF
    2017-12-23 12:53:29.482 [me.event.ThingUpdatedEvent] - Thing 'network:device:192_168_33_1' has been updated.
    2017-12-23 14:24:31.955 [vent.ItemStateChangedEvent] - Online changed from OFF to ON
    2017-12-23 14:24:31.977 [me.event.ThingUpdatedEvent] - Thing 'network:device:192_168_33_1' has been updated.

There is still no data:

Any ideas how to troubleshoot that?

Kind regards,

You could try to set log level to TRACE on your Netatmo binding in Karaf and see what more information you get.

openhab> log:set TRACE org.openhab.binding.netatmo

Thank you, Martin for your suggestion! I have changed the trace level for the Netatmo component like you said:

openhab> log:list
Logger                                             │ Level
org.openhab.binding.netatmo                        │ TRACE

But I don’t see any more data in logs:

[20:54:21] pi@OpenHAB:/var/log/openhab2$ ls -ltr
total 144
-rwxrwxr-x 1 openhab pi           0 Dec 18 13:44 Readme.txt
-rw-rw-r-- 1 openhab pi      105144 Dec 20 00:35 openhab.log
-rw-rw-r-- 1 openhab pi       25178 Jan  7 22:25 events.log
-rw-rw-r-- 1 openhab openhab    847 Jan  9 20:42 audit.log

Can I trigger Netatmo somehow to make it try to query the sensor?

Kind regards,

Hi @anton,

I do not know how one could trigger Netatmo. Are you configuring using the PaperUI or files? If you are using files, you should check that you have not changed the names of the things. See a similar problem here Issue with manual thing configuration in Netatmo binding

I guess you have tried to restart the binding and check events.log and openhab.log?

openhab> list


openhab> restart <start id>

Hi Martin,

I am happy now ) In order to force the system to write something into traces, I restarted OpenHAB and checked the traces again - I found ‘boring’ normal entries:

2018-01-09 20:01:09.368 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Scheduling update channel thread in 30 s
2018-01-09 20:01:09.642 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Successfully updated device readings! 

Just for the sake of completeness I checked the panel and - all data are there!


So, restart helped as well as your tips, which lead me to it!

Thank you and have a good sleep.

Kind regards,

Cool, glad you got it sorted