I just bought a NETATMO thermostat.
I am running OH2 1044 with binding-netatmo - 2.2.0.SNAPSHOT.
NETATMO API seems to be correctly setup as my outdoor and indoor modules are still working properly.
Thermostat, indoor and outddor modules share the same NETATMO setup in the dev setup.
The setup of the thermosat was automatically done by discovery : the check show correct setup.
I have no value reported in paper UI control insteed of that I have "NaN"
The log show the following error : every 10mn.
Any help will be usefull : I have seem similar error reported in the past in this forum but it didn’t solved my concern.

Hi yaazzz,

Did you set the readThermostat parameter to true? If so, can you please post an abstract of you log file? That would be nice. Thank you.

Hi cweitkamp,

here is the log with “log:set TRACE org.openhab.binding.netatmo” :

2017-09-24 10:07:23.710 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Trying to update channels on device xx:xx:xx:xx:xx:ee

2017-09-24 10:07:24.133 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Trying to update channels on device xx:xx:xx:xx:xx:22

2017-09-24 10:07:24.154 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Successfully updated device readings! Now updating channels

2017-09-24 10:07:24.166 [DEBUG] [.handler.AbstractNetatmoThingHandler] - Updating device channels

2017-09-24 10:07:24.202 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Updating child modules of xx:xx:xx:xx:xx:ee

2017-09-24 10:07:24.221 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Updating child module xx:xx:xx:xx:xx:cc

2017-09-24 10:07:24.243 [DEBUG] [.handler.AbstractNetatmoThingHandler] - Updating device channels

2017-09-24 10:07:24.536 [DEBUG] [netatmo.handler.NetatmoDeviceHandler] - Successfully updated device readings! Now updating channels

2017-09-24 10:07:24.557 [DEBUG] [.handler.AbstractNetatmoThingHandler] - Updating device channels

2017-09-24 10:07:24.660 [ERROR] [netatmo.handler.NetatmoDeviceHandler] - Exception when trying to update channels: null

For the readthermostat do you mean to setup it in the API netatmo thing or do I need to set it up somewhere else?

Thank you for your support.

yes, the readThermostat is a parameter for the netatmoapi Thing. You can add it in a textual configuration in the corresponding *.things file (see If you used PaperUI inbox for adding the Thing, you can switch it by toggling the checkbox.

Thank you for you answer. This is already done : in paper ui “access thermostat” is toggle. I have no idea from the logs and setup of what is going wrong :frowning:

In both cases manual or discovery I get the same result. I tried in a RPI3 with openhabian and on an odroid C2 setup specially for trying it on an other board. Same result. Don’t know what I have done wrongly :frowning:

I tried to remove the apps from the NETAMO dev site, make new setup on another computer. Still the same issue. The link with the API is working as I have the correct values reported for the inddor and oudoor modules. Any help will be very appreciated.

Does anyone have this binding working with the NETAMO thermostat? I will be interesting about the difference with my setup.

Hey @yaazzz,

I am afraid I cannot help you. May you should got to OH2 repo and open an issue over there.

I have the same issue.
The only items that get updated are the ones linked to the channels LastPlugSeen and ConnectedBoiler from the relais.

I asked the developer of the binding for help. There seem to be more problems with the Netatmo thermostat.

Hmm, the thermostat for me is definitely working in a read status without issue(almost)… I must admit the api link does on occasion seem to fail but i dont believe this is a binding issue.,…

I would suggest the following to prove where things may be going wrong.

Completely remove all things/items/links etc relating to Netatmo. Uninstall the binding… wait for it to complete, re-install.

from PAPERUI (just this method only for now) add the netatmo api connection. Then run a thing search for the netatmo binding. If all your devices are defined in the netatmo site properly it should pick everything up so that they can be added and used.

(I say almost, because boiler on and off times have never worked for me)

Thank youChristoph and Mike. I made new setup from scratch : Odroid C2 + armbian. I don’t know why but everything is fine now. Thank you.

I still have the exact same problem and i don’t how how to solve it … (OpenHAB2 2.2.0-SNAPSHOT build #1044).

same issue here. any update on the topic?
only thing i see is this:

ent] - 'netatmo:NAMain:home:70ee5016239c' changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)
2017-11-11 23:26:19.983 [hingStatusInfoChangedEvent] - 'netatmo:netatmoapi:home' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): An error occurred while calling station API : 400 Bad Request
2017-11-11 23:26:20.005 [hingStatusInfoChangedEvent] - 'netatmo:NAMain:home:inside' changed from ONLINE to OFFLINE (BRIDGE_OFFLINE)

No, there aren’t. Please follow the linked issue of my comment NETATMO BINDING : THERMOSTAT NULL response.