Netatmo error HANDLER_CONFIGURATION_PENDING after update to OH 2.2 (from 2.1)

Tags: #<Tag:0x00007fc90da63be0>

I just upgraded my OpenHAB installation (via apt get) from release 2.1 to 2.2, now I do net get any of the Netatmo items to get any update anymore.

Checking the console the binding is up and running

openhab> list | grep etatm
229 │ Active   │  80 │ 2.2.0                  │ Netatmo Binding
openhab>

I also did restart it but it seems to have no effect. It was working fine with 2.1.

Here are my settings:

 Bridge netatmo:netatmoapi:home [ clientId="584...20", clientSecret="...secret ...", username="my-user-here", password="my-password", readStation=true, readHealthyHomeCoach=true, readThermostat=false] {
 	Thing netatmo:NAMain:home:inside     "Netatmo Inside"  [ equipmentId="70:ee:50:27:28:aa" ] 
 	Thing netatmo:NAModule1:home:outside "Netatmo Outside" [ equipmentId="02:00:00:27:4d:a4", parentId="70:ee:50:27:28:aa" ]
 	Thing netatmo:NAModule3:home:rain    "Netatmo Rain"    [ equipmentId="05:00:00:02:97:74", parentId="70:ee:50:27:28:aa" ] 
 }

items are like this:

Number   Netatmo_Indoor_Temperature    "Wohnzimmer Netatmo Temperatur [%.2f °C]" <temperature>     (OG_Wohnzimmer)  { channel = "netatmo:NAMain:home:inside:Temperature" }

Number   Netatmo_Indoor_Pressure       "Luftdruck [%.2f mbar]"                   <pressure>        (Wetter)  { channel = "netatmo:NAMain:home:inside:Pressure"}

Number   Netatmo_Outdoor_Humidity      "Außenluftfeuchte [%.2f %%]"              <humidity>        (Wetter)  { channel = "netatmo:NAModule1:home:outside:Humidity" }

Has anyone seen the same behavior and has an idea what to fix?

not sure if this will help, but try: Clear the Cache

… unfortunately this did not help.

In the log I can see

2018-02-13 13:33:00.397 [INFO ] [netatmo.handler.NetatmoBridgeHandler] - Initializing API Connection and scheduling token refresh every 5400s

The only issue I can see is this

2018-02-13 13:30:01.430 [INFO ] [el.core.internal.ModelRepositoryImpl] - Validation issues found in configuration model 'netatmo.things', using it anyway:
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>
Provide a thing type ID and a thing ID in this format:
 <thingTypeId> <thingId>

but I did not change the thing definition and I can not remember if this error was reported in OH 2.1 as well.

most likely, the syntax has changed and the checks are stricter… check the docs and the forum for recent examples

OK this really seem to be the reason. Thanks for pointing it out.

The new setting now looks like this:

Bridge netatmo:netatmoapi:home "Netatmo API" [ clientId="584..20", clientSecret="VY..gw", username="my-user-here", password="my-password", readStation=true, readHealthyHomeCoach=true, readThermostat=false, readWelcome=false] {
 //	Thing netatmo:NAMain:home:inside     "Netatmo Inside"  [ equipmentId="70:ee:50:27:28:ca" ] 
    Thing NAMain    inside   [ id="70:ee:50:27:28:ca" ]
 //	Thing netatmo:NAModule1:home:outside "Netatmo Outside" [ equipmentId="02:00:00:27:4d:a4", parentId="70:ee:50:27:28:ca" ]
    Thing NAModule1 outside  [ id="02:00:00:27:4d:a4", parentId="70:ee:50:27:28:ca" ]
// 	Thing netatmo:NAModule3:home:rain    "Netatmo Rain"    [ equipmentId="05:00:00:02:97:74", parentId="70:ee:50:27:28:ca" ] 
    Thing NAModule3 rain     [ id="05:00:00:02:97:74", parentId="70:ee:50:27:28:ca" ] 
 }

and after some issues and a bundle restart all Things are Online now.
I will mark this as solution, so others can look it up.

Hey guys,

have to reopen this thread because it’s not working for me.

I’m not getting the API online. Same error you had but I still updated the syntax.

What I am wondering about is that in die manuelly build *.things - File the clientID is inserted. But if I am looking up the clientID in the PaperUI it’s missing. And… Paper UI is not saveing it.

I don’t get it… what I am doing wrong?

Thx for help
Marcel

Sorry for reopening this thread. I tried to get the binding up an running. I have the same result, as far as I can see. @sancho2k, where you able to solve your issue?
In the log I can see the following messages:

2020-09-29 20:16:11.045 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'netatmo.things'

2020-09-29 20:16:11.088 [me.event.ThingUpdatedEvent] - Thing 'netatmo:netatmoapi:home' has been updated.

2020-09-29 20:16:11.095 [hingStatusInfoChangedEvent] - 'netatmo:NACamera:home:camera' changed from UNINITIALIZED (HANDLER_CONFIGURATION_PENDING) to UNINITIALIZED (HANDLER_MISSING_ERROR)

2020-09-29 20:16:11.104 [me.event.ThingUpdatedEvent] - Thing 'netatmo:NACamera:home:camera' has been updated.

In Paper UI the Netatmo API appears online. But my camera has an error: Status: UNINITIALIZED - HANDLER_CONFIGURATION_PENDING

My netatmo.things config:

Bridge netatmo:netatmoapi:home "Netatmo API" [ clientId="myclientid", clientSecret="mysecret", username="myusername", password="mypassword", readStation=true, readHealthyHomeCoach=true, readThermostat=false, readWelcome=false] { Thing NACamera camera [ id="70:ee:50:32:62:c4" ] }

Not sure if it might be related. Upon registering my app on https://dev.netatmo.com/apps I did not enter a webhook URI or redirect URI. Since in the documentation it mentioned for it to be public. By public I assume it is meant as in the internet. Which my OH installation is not.

I was able to solve this. If anybody stumbles upon this thread, here is the solution.
My config was missing the home id. As mentioned in the manual:

    Thing NAWelcomeHome home   [ id="58yyacaaexxxebca99x999x", refreshInterval=600000 ]
    Thing NACamera camera [ id="cc:cc:cc:cc:cc:cc", parentId="58yyacaaexxxebca99x999x" ]

I found the home id by connecting directly to the API with python. The more simple approach is to not use the configuration through a file for the thing. Instead use the web UI to config the netatmo elements.