Netatmo handler and item errors [fresh install]

  • Platform information:
    • Hardware: RaspberryPI 3B+
    • OS: Openhabian / Raspbian Bullseye
    • Java Runtime Environment: 17.0.7
    • openHAB version: 4.0.2

Issue of the topic:
I recently had to re-setup my openHAB configuration, as an upgrade to version 4 failed and I was to tired to find the issue. So I reinstalled my bindings, setup the things and re-loaded my items file configuration. All works properly, however, I keep receiving 2 errors from the netatmo binding area, which I am unable to resolve. Maybe you guys are able to provide a solution or let me know, where I need to dig into.

Here is a screenshot of the frontail log:

Both warnings - handler already disposed and item value conversion - did not appear on my previous installation.

Thanks for any help, Georg

Well, the value conversion WARN is due to the incompatible units of both channel and item.
In openHAB4 there are more strict tests about the unit, so you have to take care of correct configuration.
The channel gives mm/h while the item unit is set to mm.
In fact (although it’s not the “correct” measurement) you will have to use Number:Speed to set the Item unit to mm/h.

In question of the other WARN, I have no idea.

Thanks @Udo_Hartmann - I changed the item configuration and it seems to work now.

However the “disposal” warning keeps confusing me and also spaming my log… Any other ideas?