Netatmo - openhab has forgotten "grant connect"

USing Netatmo with V3.4. After each start of openhab I’ve to repeat the step

Configuration incomplete, please grant the binding to Netatmo Connect.

How to grant it for ever?

Is your thing defined in UI or file?

Hi Lolodomo
thanks for the hint. I’ve defined “account”, “weather-station” and “rain-Modul” in the things-file. While the “account” went online, the two others remained on “configuring/error”. So i did a scan. The founded things did work - but loosing the connection with every restart. The result was that the “account” was from file, and the remaining from UI.
I’ve removed the things file and did now all in UI, and it’s working.

Or you could have set the appropriate token parameter in your thing file for the account thing.

Hi!
I have updatet OH to version 3.3 from 3.2.
I try to add my Netatmo again, but its not working.


I have already restarted OpenHAB once, but it did not help.
API access should still work, as it has worked so far.

You should find help with steps to follow in the binding documentation.

Would be cool if maybe the link is listed at the bottom of the setup process so you only have to click there.

“Next press [HERE](http://:8080/netatmo/connect/<CLIENT_ID>)” or something linke that.