Netatmo temperature values with multiple decimals on dummy widget


i’m new to openhab but have already running openhabian on the raspberry pi.
I’ve also managed to add all my Netatmo modules to things file and they are online.

Adding an item for the indoor temperature shows a nice looking value in the paper ui like 25.3 °C.
When it comes to HABpanel using the dummy widget i always get a number with more than 10 decimals.
I found different solutions here in the forum but no one worked for me.

Here is what my itmes file looks like:

Number:Temperature Netatmo_Indoor_Temperature         "Temperature [%.1f %unit%]"          <temperature>      { channel = "netatmo:NAMain:home:inside:Temperature" }


Number:Temperature Netatmo_Indoor_Temperature         "Temperature [%.1f °C]"          <temperature>      { channel = "netatmo:NAMain:home:inside:Temperature" }

has the same result.

Adding the format to the dummy widget leads to an empty widget field after i saved the changes.

Before i had added all Modules of the netatmo with simple mode on the paper ui and had the same result so i tried to use the *.things and *.items files hoping to have better result.

You need to use:

Number:Temperature Netatmo_Indoor_Temperature         "Temperature [%.1f °C]"          <temperature>      { channel = "netatmo:NAMain:home:inside:Temperature" }

And tick the server provided format in the dummy widget:


when you link the temp to the dummy widget there is a selection to use the system format . or something like that. sorry can’t remember at this moment and I am near my system as I have every thing off busy building and removed server from the flat for prevention of dust Ingres

have look above.


thanks for your quick reply.

If i activate this i get an empty dummy widget only showing the label:

btw: i’m running openHAB 2.3.0 Release Build

and here are the settings:

sorry for double post but new users are only allowed to post one image

There was a problem with displaying the Units of Measurement items in HABpanel.
This has been fixed but I don’t know in which release.
You may want to upgrade to the next milestone:

See the Testing release in:

Assuming that you are running debian linux or openhabian

wohooo :slight_smile:

i switched to testing release which is at the moment 2.4.0 milestone testing and now the temperature is correctly displayed.

thank you very much for your help!