Network Binding not working (solved)

  • Platform information:
    • Hardware: Raspberry PI 3B
    • OS: Raspian
    • Java Runtime Environment: zulu 8
    • openHAB version: 2.5

My Network bindings does not find anything even if my network is full of pingable devices.
I tried with OH windows version and it works very well but on pi this does not work.

If I try to add things manually the device is created in things but it does not connect.
arping at device IP works and arping is well installed in /usr/sbin/arping

Other bindings like Samsung TV are well working.

What can be the issue ?

can you ping from the command line? Not arping, just regular old ping.

In addition to Rich’s post:

Can you show your configuration?

What minor version? 2.5.10?

1 Like

Yes 2.5.10.

PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=1435 ms
64 bytes from icmp_seq=2 ttl=64 time=418 ms
64 bytes from icmp_seq=3 ttl=64 time=201 ms
64 bytes from icmp_seq=4 ttl=64 time=256 ms
64 bytes from icmp_seq=5 ttl=64 time=1104 ms
64 bytes from icmp_seq=6 ttl=64 time=28.7 ms
— ping statistics —
6 packets transmitted, 6 received, 0% packet loss, time 102ms
rtt min/avg/max/mdev = 28.695/573.691/1434.980/513.816 ms, pipe 2

I checked bundle status list. They are all active except:
openHAB Add-ons :: Bundles :: Network Binding --> waiting …
openHAB Add-ons :: Bundles :: IO :: MQTT Broker Moquette --> waiting

May be this has something to do with the problem

Finally I recognised there was a mess between MQTT Mosquito running on pi and the OH MQTT binding that were entering in conflict.
I have uninstalled all the Bindings (MQQT and Network).
I have manulally deleted mqttmouquette.
I cleaned the cache
Sudo reboot

After I have reinstalled Network Bindings and it works perfect.
This problem is regarded as closed.

I spent a lot of time this night in reading and I guess that most of the issues are well documented in thi comunity together with fix suggestions. I love this :slight_smile:

Good work!

It sounds like you had two MQTT brokers installed?

If you still need MQTT, I’d strongly recommend (only!) using Mosquitto as your broker, rather than openHAB’s in-built Moquette.

If you’re on openhabian you can install it from the configuration menu. If not, start here or Google for your device!

Thank you for the advise. Indeed I have mosquito running on pi and well working( can connect and hello world. All my sonoff connect.
Unlikely I sill have some issue with OH MQTT brrocker (bridge does not connect and I’m trying to understand why). But this is another issue and , if I will not find a solution on the community, I will post a new :slight_smile: