New 433 Mhz CUL and Intertechno Binding

It was hard work :wink:
Anyway…stuck in alexa and cul. I have created a group in the Amazon Alexa group which switches all lights on. After switching about 8 Intertechno devices (one after another) the culs red light is blinks rapidly. Green light is off. The cul hangs up. I have to restart the whole system then.
Manual switching always works fine.

That could be either he separate threads that try to use the CULat the same time ( because each send is run in a separate thread) or the build-in limit of messages per time in the CUL. More probably the first one.
A way to overcome is to look if the used switches do allow a ALL-OFF command (not all have that). Otherwise only a rule that switches one after the other with a sleep in between will help.

Hallo together

over the last week i started with openhab, mi goal is it to migrate mi old “system” from smartwares and Intertechno in to openhab and extand it.
i have the follow components:

i readed a lot in the community but i couldn’t bring it to work with the raspberry pi 3 and a busware cul 433MHz USB dongel. I configured the dongel how in this description:

  • Youtube - watch?v=nMqaZkV_Ols

My my culintertechno.cfg looks like this:


the intertechno.items like this:

Switch  Schalter_Wand     "Licht Wand"       {culintertechno="type=raw;address=0000C49FO1;commandOn=FF;commandOff=F0"}
Switch  Schalter_Stern    "licht Stern"      {culintertechno="type=raw;address=FF00FF00FF;commandOn=FF;commandOff=F0"}

and the test.sitemap like this:

     Text label="Wohnen" icon=sofa {
         Frame label="Licht"{
             Switch item=Schalter_Wand label="Wand" icon=switch
             Switch item=Schalter_Stern label="Stern" icon=switch

The upper code i got from the Smartwares-System. If i now Switch “Wand” in de Basic UI the green LED of the CUL is making a short flasch but nothing happens (usualy the LED of the CUL is togeling from green to off, in a clock of 0.5s) the same is happening if i try to get the “Stern” (with the new code).
I would be very thankful for some advice.

What is the logfile output concerning the cul. YOU Can see it in the startup logfile of your openhabian. Otherwise look through my former postings. I described the nearly the same configuration and completly solved the Intertechno and Cul thing.

ACM0 will definately not work.

Why shouldn’t that work? It depends on how the CUL is connected, my CUL(866) is connected as ttyACM0 and is working!

Your culintertechno.cfg is WRONG!
The syntax you copied is from OH1, which used a single config-file for all addons. OH2 has dedicated files for each addon, like your culintertechno.cfg.
Just remove the “culintertechno:” in each line!

I’m not terribly sure that the code for the first ligth would work!

I read sw. that ACM0 belongs to Rpi2 … for Rpi3 it´s USB0

I had used the CUL (866) on a Raspi2 as I use it now on my Raspi3 as ttyACM0!

I get it work now… i removed the “culintertechno” in the culintertechno.cfg:


# How often should the command be repeated? (optional)
# See for details

# How long should one pulse be? (optional)
# See for details

and changed the configuration in the intertechno.items to:

Switch  Schalter_Stern    "licht Stern"      { culintertechno="type=raw;address=01010110000100010110010110;commandOn=010000;commandOff=000000" }

and the rest was okay, in this case the config “device=serial:/dev/ttyACM0” is working well.

Now i have just to figure it out how to dim the intertechno ITDM-250.

Thanks to @opus and @Marko_Kraft for the fast support

You’re most welcome and real lucky to get it working.
Since I used a 866mhz CUL so far, I decided to switch to a 433 nanoCUL. This one comes on as ttyUSB0 and I can’t get that one to work with OH😣

What’s wrong? I got 433 and 868 nanoCUL running in parallel.

What is interesting, in both cases I am using ttyUSB0 or ttyUSB1.

(I have not confirmed if 868MHz is really working because I am not controlling anything).

Can’t say what’'s wrong besides that the nanoCUL is not sending from OH.
I’ll have another test-session tonight. Will report back.

Yeah, I recommend first checking that openhabian or your user loading OH is part of the dailout or TTY group.
I had the same issue recently on Ubuntu when programming my EPS8266 over FTDI (which will also show up at /dev/ttyUSBx).

I believe to have checked all that, posted here: (Solved)nanoCUL not responding to OH2

Hi guys,

Please tell me if you know it. Can i with with cul stick and this or maybe other binding recieve 433mhz signals? Only receive and accouring the rules make somethings in Openhab.
For example if i revieved signal from 433mhz remote button 1 then make something.
Or is it only with Intertechno compatible?

If you have any other idea how can i realize it, please tell it!

Please do not offer Somoff RF Bridge, because even with tasmota it do not receive commenads from 90% new remotes.

Thanks a lot!

As far as I can tell a CUL stick can receive only on the frequency it is build for (433 or 866mhz). Sending is possible for the 833 version on both frequencies. But that is all I can say about that.

Thanks !
I understand it, i need only receive. But the question - can i receive all the codes not only from intertechno?

IMHO: If you do receive, you’ll get all codes (intertechno or not).

So i can make items and follow the states of them in openhab with rules?
Do you have this stick could you please check it or it is only IMHO?)))

Accroding to this message New 433 Mhz CUL and Intertechno Binding i have found instructions how to send codes with OH, but not how to get them(((
I can get then only in minicom, but not with openhab, am i right?