New Aeotec Door/Window Sensor 7 not in Database yet?

Tags: #<Tag:0x00007fc3fde078b0>

That’s fine - this is included in the database for a long time as it’s not new that Aeotec have the two IDs…

1 Like

Done … almost.
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1065

I don’t have time to add the config parameters today, so please wait until next week or add them yourself.

perfectly fine for me to wait until you have time to do it. thanks.
just hat a quick look into the link above … its says, that the device does not support security … this is not true, it supports S2. Do the ENDPOINTS than also need to change?

Found a minute … done.

No, it’s just information.

1 Like

thanks for your quick help!! much appreciated
I just downloaded the most recent zwave jar file, but could not get it to work:

2019-06-30 20:39:04.568 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler

2019-06-30 20:39:06.718 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [251]

  Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]

I actually come from the binding dated April 26. Is there anything else I need to do?

1 Like

@mhilbush do you advise to upgrade from openhabian 2.4. stable to a 2.5. snapshot? (I also have the issue with the USB ports after reboot and need to re-include all my zwave things after a reboot of the system … and this is supposed to be fixed now)

Sorry, but I’m going to give you one of those “it depends” answers. :wink:

It really depends on what other bindings you’re running. There’s still fallout from the migration to the new build system. Several bindings are broken in the most recent snapshots (although it’s getting better every day). OTOH, I’m running the latest snapshots on two production systems, both of which are very stable.

If you’re happy with 2.4, and just need the latest zwave binding, updating just the zwave binding probably is the way to go. And, I don’t think we’re too far away from a 2.5 M2 milestone build – maybe a month away. So, from my perspective (and I say this not knowing anything else about your installation) I’d stick with 2.4, update just the zwave binding, then upgrade to 2.5 M2 when it comes out.

1 Like

@sihui : I just downloaded the zwave binding again (version from July 2nd). When I look at the list of supported devices, the ZWA008 is not included yet. Is there still something missing?

I have not updated the binding yet so it will not be included. I will try and do that tonight.

2 Likes

I just tested with Snapshot 1629 from tonight but the device is still not recognised.

In the device database on cd-jackson.com there is displayed a symbol which seems to indicate that there are still some information missing?

Please be patient, it has not made it into the snapshot yet:

1 Like

@sihui
I got the device added to my system now, but can’t get it secured.
I will send a private message with the log file to you and Chris.

Any update on this? I notices that in the database this is still marked as “More information required” which I assume means it’s not in the current openhab Z-Wave module. @chris is there anything I can do to finish this out? I just bought 2 of these devices and want to see them in action.

Cheers! :slight_smile:
=C=

It looks like it was added to the binding 6 days ago, so it should be in the latest build.

1 Like

Oh sweet. thanks you. :slight_smile:
=C=

n00b question but is the zwave binding in the milestones?

I used to have it manually installed after I helped add something to it but went back to the “production” version after 2.4. If I get the milestone release will I get the new zwave binding or do I need to go back to manually installed?

Cheers! :slight_smile:
=C=

@calevans
do you plan to install the sensor with security on? If so, I will wait for your install before I try again. Secure include did not work for me about 3 weeks ago.

The latest zwave binding will be in the snapshot release only (until there’s a 2.5 M2 release to pick it up).

You can install it manually, or you can try to update it as described in my post here.

1 Like

This did NOT work for me. :slight_smile:
Well, somethings changed. Here’s what I did and what happened.

I followed your instructions. The first time it failed but it seems to have been a permissions issue with the old 2.4.0 jar file. I made it world writable and then tried again and it worked…kinda.

Now I have ZWave installed via PaperUI I don’t know if that’s important.

The FIRST time I got the upgrade on the console to work, everything seems to have worked just fine. I used the command:

bundle:update org.openhab.binding.zwave https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/binding/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar 

Then I checked the results with:

list -s | grep zwave

So far, so good, it listed the 2.5.0 jar with a long string of numbers that I assume is the snapshot or build number.

I rebooted my system.

Everything came back up.

I went back into the console and issued the ls command again and it was back to 2.4.0. :frowning:

So I tried the update again.

Everything seemed to have worked, it was showing the 2.5.0 again. BUT. I got distracted for a few minutes and then just to make sure, I did the ls command again and it was back to 2.4.0.

Long story short, I could not get it to stay on 2.5.0. I eventually uninstalled it form the console, uninstalled it from PaperUI, rebooted and reinstalled 2.4.0 from Paper UI. (I cut out about an hour of banging my head on the monitor and trying different permutations.)

I now have 2.4.0 up and running just fine but obvs, I can’t use the sensors yet. :slight_smile:

Have you ever seen it where the upgrade works but then it reverts to the older version? That jsut seemed odd.

Nothing else is running on this system, it’s a little RPi dedicated to openhab.

Thots?

Cheers! :slight_smile:
=C=