New amanda release 3.5.1 complains about amanda configs created by openhab-cli

Just installed fresh openhab-2.3.0 to an up-to-date ubuntu 18.04.

After setting amanda and tried to do a first backup “amdump openhab-dir” reports

'/etc/amanda/openhab-dir/amanda.conf', line 11: warning: Global changerfile is deprecated, it must be set in the changer section

I tried to grasp what the changes to amanda.conf look like by reading the amanda documentation but honestly amanda.conf and especially it’s documentation is in large parts like reading a foreign language. I found out that you now use ‘changer’ sections, but what exactly their content should be and which one is the default one etc. is completely out of my sense of understanding amanda.

I think we should update the amanada config generation script to generate valid config. If anyone could post an updated one (or more precise instruct what I need to change) it would be great.

ATM: It seems that amanda still does the backups it’s just a warning but often a few releases later things just stop

Any help would be greatly appreciated

1 Like

Did you install openhabian on top of Ubuntu ? You didn’t mention, and if no and you deliberately installed Amanda next to openhab, you shouldn’t be asking here as that’s no openHABian issue then.
Amanda on ARM is not available as a package for the latest version, it is still on version 3.3.9 and that’s what the generated config works for. Most openHABian users run ARM hardware thus this version. You could also install that one.
I don’t have a PC at hand to run 3.5.1. See this link at the bottom for the changer section. Probably you should move those params mentioned there into that section and possibly also reference it. If you manage to cobble together a changer section config to work with 3.5.1, let me know. If it also works with 3.3.9 I can make that the openHABian default.

Hi Thanks for your reply, I’ll try to answer your questions first:

I took the latest ubuntu 18.04 minimal for my platform (odroid xu4) and installed openhabian via apt-get package manager on it. Just to be clear, I didn’t install amanda manually but by openhabian-config and it installed version 3.5.1 obviously.

As it seems when a newer version of amanda is available on the distro it will install that one instead of the specific 3.3.9 which would then make more sense.

What I would question though is that there’s no newer arm package for amanda. My “uname -a” reports this:
Linux odroid 4.14.55-146 #1 SMP PREEMPT Wed Jul 11 22:31:01 -03 2018 armv7l armv7l armv7l GNU/Linux and it was installed by openhabian-config via apt package manager. So it seems it is available at least for some arm processors.

I will try though to cobble together a changer section when I have time which will not be for the next days.

Thanks for info though.

hmm, can you let me know which repository you obtained the Amanda packages from ?

[22:30:37] root@openhabianpi:/etc/openhab2/items# apt-cache policy amanda-common
  Installiert:           1:3.3.9-5
  Installationskandidat: 1:3.3.9-5
 *** 1:3.3.9-5 500
        500 stretch/main armhf Packages
        100 /var/lib/dpkg/status
[19:51:52] openhabian@odroid:~$ apt-cache policy amanda-common
  Installed: 1:3.5.1-1build2
  Candidate: 1:3.5.1-1build2
  Version table:
 *** 1:3.5.1-1build2 500
        500 bionic/universe armhf Packages
        100 /var/lib/dpkg/status